Accent hits delayed???

Why do my accents not hit until after I have released the footswitch. It makes it impossible to use the accents in tempo. I watched the video of the dude playing Zepplin and he hits the accents right in time. I have gone through every adjustment I can think of in the footswitch settings and nothing helps. In fact, on some folders/songs, the accents disappear.

What footswitch do you use? Did you use footswitch detector function?

My left switch only works every second hit. I vaguely recall the footswitch set up. Can someone refresh me? Or is this a different issue?

Step 1: Press ‘Drum Set’ knob and ‘Tempo’ knob both at the same time.

Step 2: Choose ‘Footswitch’ option (by pressing the ‘Tap’ button which is located above the ‘Tempo’ knob)

Step 3: Choose ‘Footswitch Detector’

Step 4: Follow instructions on screen