Aeros 5.0.0 beta

I did exactly as David’s instructions from forum, the Aeros detected update and ask me if I wanted it updated and when I pressed yes it shut off then turned back on by itself than went back to the same firmware as before. I looked on my SD card it said file was empty. I’m stumped :thinking:. I just got my Aeros last Friday and I really didn’t want to learn the older version when I can start from scratch on the new upcoming firmware release. Thanks

You need to follow the instructions for manually updating the beta using the SD card.

Yea that’s what I meant I did the manual SD card update.

Your description from your first post sounded like the WiFi method :grinning:

Just to make sure, these are the steps:

How to Update to Aeros Firmware 5.0.0

  1. Download the 5.0.0 update file here and place it on your SD card
  2. Rename the 5.0.0 update file to “aeros.bin” once it is on your SD card.
  3. Insert the SD card into the Aeros SD card slot while the Aeros is off, and turn the Aeros on. The Aeros will take about 10 minutes to update.

If you’re still having problems, make sure you’re using an SDHC Class 10, no larger than 32Gb SD card and that your card is unlocked. Shouldn’t need to be formatted but just in case, it should be MS-DOS (FAT32).

If you’re still having problems, please reach out to Support Support,

i downloaded it and extracted files and it wants to open it in the windows media player??I don’t know wth I did wrong I’ve been at this since 8am!!! That link that’s on your post is not the right one or it’s corrupted I reformatted my SD card, I put it in my SD card and it just don’t work.

Since the file does not have a .zip in the title, you don’t need to extract it. Just drag or paste it to your SD card and rename it.

Recommend you delete what you tried to extract and download it again as the file you tried to extract may no longer be viable.

1 Like

I just tested it again. It’s the correct link and the file is not corrupted.

Probably didn’t need to do that if you had not previously done so.

An awful long time to be spending on this process. Might be helpful to put your Aeros away for the day and try it again tomorrow when you’re fresh and not frazzled.

Hopefully the video tutorial posted above will help you.

where di you hide the 5.0 firmware. I followed the link provided
under How to Update to Aeros Firmware 5.0.0 and it is not there? I also looked in a few other places and cannot find.

It’s there. You just need to click on the blue text.

But just in case you’re still having trouble, you might want to head back to this thread where you’ll find the original link to the beta firmware file

Yes, I was clicking on the blue text and the link led me to a dircetory that had a manual and some beatbuddy firmware, but no Aeros 5.0. I went back and followed the original link as you suggested and found it there. Dont understand why, but I am good. Thank you for the very quick reply!!

1 Like

I’ll try again in the morning I don’t know what I did wrong it keep coming to the same conclusion windows was asking if I wanted too look for app online to unzip that type of file, perhaps I never extracted the file? Sorry I’m a musician not to keen on this it’s frustrating it’s probably something stupidly simple thanks for your patience. Good idea need a drink or two,take a break, try again tomorrow morning thanks again.

1 Like

Try this file 99.07 MB file on MEGA

  • Unzip
  • In the folder you will see a files "aeros.bin
  • The file is the 5.0 beta and is renaming like it must be
  • Follow the instruction on the video
1 Like

Thanks I tried the link so it’s something on my end, update my Beatuddy same way w/o any problems idk? Anyway support sending me a SD w/5.0.0 beta, how cool is that! Great support & community, couldn’t ask for more. Just wanted to say thanks forgot to reply.

1 Like