BBmanager : Chain parts in 4/4 and in 5/4 inside the same song

Hi there,

In the same song, I am struggling to figure out how to chain a part in 4/4 (2 bars looping), with a part in 5/4 (2 bars looping), on the same tempo. The problem is the size of the second part… I cannot limit it to 10 beats…

Here is what I did for the moment. Note that the rythms are exactly what I want, and they chain perfectly for me, but I cannot figure out how to trim the second part to the right size (I put a crash to show where it should end and loop).

I put a metronome to show the constant beat. 2x 4 beats in the first part. 2x 5 beats in the second part.

Thanks for your help.

I have a couple of songs that mix time signatures, but I had to build the patterns manually. Reaper (for example) lets you save the time signature with the MIDI part. You just place the parts in your song and transition from one to the other. BB will maintain the BPM regardless of the time signature of the part being played.

In the example I posted, I created both part manually, but I still can’t cut the end of the seecond pattern on the 10th beat. I put 5/4 in the signature, but if I select 2 bars, it will cut at 8th beat, not 10th… What am I missing ?

Infact, in BB, the upper number of the time signature does not seem to have any influence on the length of the pattern. Which is not logical… A measure of 5 beat is longer than a measure of 4 beats…

I made another test :
I created a new song based one 2 factory patterns of the BB. One pattern in 4/4, and another in 5/4.
In this case, it works. Both patterns chain perfectly, and if I edit them, the first has 4 beats per bar, and the second a 5 beats per bar. And if I try to change the number of bars of each pattern, it increments by 4 beats in the first pattern, and by 5 beats in the second pattern. Everything is ok.
Here is the file, if you want to try :

So what am I doing wrong with my file ? I double checked : my patterns are also clearly labeled 4/4 and 5/4, so why BBmanager does not cut the second pattern in 5 beats chunks ???

The issue is that you have to make sure your MIDI editor is including the time signature in your MIDI file. They don’t all do that automatically, and I have been caught more than once forgetting that, so Reaper writes the MIDI file with no time and BB “appears” to assume it’s 4/4.

1 Like

Post the MIDI files for me to look at, not the song. Extracting the MIDI from the SNG file will not necessarily give me the MIDI files you’re starting with.

1 Like

Oh, I think I got the point.
The file I uploaded with the simple rythms were made from scratch, BUT I first make the 4/4 beat, and then, being lazy, I exported it into MID and reload it into the second part, thinking I could change the signature to 5/4 and adding some notes to fill the gaps.

BUT it seems that BBmanager does not accept that : once the MID file is loaded with a time signature, you cannot change it from BBmanager !!! (maybe a little bug ?)

After realizing that, I tested creating the second 5/4 pattern from scratch and it worked !!!

So first problem solved.

Then second problem : I want to record my 5/4 pattern in a sequencer and import it into BBmanager.

So as you requested, here is the MID file I recorded in Cakewalk, using a 5/4 signature, tempo 80.

But it seems that when exporting, there is no time signature in it…

Apparently cakewalk does not export this data… when exporting a single clip.

Then I tried exporting by another menu, and it seems to include the signature (I see it if I try to open it back), but BB gives a error when loading it…

As as BBmanager does not want to change the signature of an imported clip, I’m stucked…

1 Like

It’s not a “bug,” it’s a “feature!”

Seriously, I believe it works exactly as expected, and I have taken advantage on a number of occasions.

Glad it worked out for you – sort of.

I use Reaper, and it works great. You can download it for free and use it for a period of time before they ask you ever-so-gently to buy it. And it’s not expensive if/when you do.


Yes it’s a nice feature to read MIDI file signature, but you should be allowed to change it afterwards. :slight_smile:

Afterall, you are allowed to change the time signature of a pattern made in BBmanager at any time…

I’ll have to find a sequencer that export signatures in midifile…

“but you should be allowed to change it afterwards.”

Two answers: And you can – in a MIDI editor; and no, you really shouldn’t, because without an editor, you aren’t telling BBM what you want to do with the extra beats or which beats to cut.

I do not understand your last point : in the left panel of the BB midi editor, you can enter the time signature and the number of bars. These 2 informations are what it needs to calculate the total length of the pattern, and the position where it should cut. Ex: 5/4 x 2 bars = 10 beats. 4/4 x 4 bars = 16 beats, etc…
And it does work like this when you create a pattern from scratch. I tested it.
But in the case you imported a MIDIFILE, the time signature of this left panel has no more effect and the midifile signature overides it. :frowning:

Ah! I did not know that, because I don’t use the (user-created, not Singular-created) built-in MIDI editor. I just learned something new. And it hurt, just a little bit!


1 Like

Anyway thanks for your help : at least now I know a (not simple) method to treat my midi recordings.
By the way, I tested Reaper and could you tell me in one word if it is simple to load a midifile and play it directly with a simple General Midi internal software synth ?

Want more words? Load it as a track and set the output device to GM MIDI.

And you’re very welcome!

1 Like

Ok to load the mid file, in one track, but where do I find this output device ? Not obvious.
And is there any virtual instrument in Reaper that mimics GM ?
Or can I route the output to the internal GMS table that I activated in the MIDI options ?

Click the “I/O” button/window next to the track name.

Do not find this I/O button…
I do not understand, because I declared my MIDI output to GMS soudn card default synth (that works outside reaper, I check)

It appears you have turned off some functionality. When you restore it, the control is here:

(Or maybe I am a version behind you and it all changed?)

Strange. I just installed the very last version 636, and made no modification, I just choose MIDI device and AUDIO device… See my mute and solo buttons are not at the same place.

EDIT : oh, it’s in the mixer, that I just opened. The “route” button