Beatbuddy and Infinity Looper different

Hi everybody,
im going crazy today because my problem.

  • multi sync, input split and series mode are off
  • stop mode full/all
  • beatbuddy is connected to the lopper over midi out

When i record a phrase to the infinity looper with beatbuddy tempo for example 80 beats and i play back, the recorded phrase of the looper is much more slow then i playd. This behavior is on all songs of the beatbuddy.

Can anybody help me with this problem?
Is there a way to reset the looper to factory settings?


Is Varispeed enabled? You have to look in application… Hope this helps.

yes, see screeenshot


Check your manual for reboot settings. I think there is a list of somethings t hat you can change by holding down buttons when you power it up. Also, try loading a loop on the application and make sure that it is working right. Under tools there is a global settings options and an option for enabling or disabling when booting the pedal. I am at work now so I am going by memory.

Okay, I think you cant set varispeed off in application, but somehow... Am searching in the manual. Got my infinity before 2 days, and had the same problem, but cannot remember how Ive fixed it. Am also trying and have so much errors… Have to read the manual… Sorry, but when I find out, I post how…

sorry but i dont know what to do because im newbie.

Can you look to my scrennshots after work ?



Record your phrase with the BB connected, then stop the BB. If the looper stops too, restart your phrase on the looper. Do not disconnect the BB. Is the phrase the same or different when the BB was going?

the phrase is different!


@897 This may possibly be an issue with your Infinity looper. Do you have the most updated version of it’s firmware? If not, you should update it. If after updating the Infinity’s firmware to the latest version you are still experiencing these issues, please let us know.

i updated yesterday so infinity has the last version and the problem is still here.
So what can i do?


i cannot understand why.
i started betbuddy to record a phrase to the looper. Everything was perfect. I deleted the phrase and recorded another one, wonderful i thougt. The third new phrase was the same problem because the pitch was not the same as i recorded. I dont know what to do?


I don’t know if it will make a difference but your midi channel is set to 2. Mine is set to 1 which I think is the default. Also I think some of the latest updates address issues with the beat buddy and how it syncs with the infinity. I have no problems with the loops but if I change the beat and then start – the infinity changes pitch in relation to the tempo, I think there are some different options in the updates that relate to recording in series or parallel mode and whether or not you set the infinities stop mode to all or arm. I don’t remember anything in the manual showing you how to reformat the infinity back to factory settings but Pigtronix would probably show you how to do that if you drop them a line. I had issues with my pedal and thats what they did for me.

Hi, i switched the midi channel to 2 because my tc-helicon voicelive play gtx has channel 1 to switch the presets. At this time i did not connect it to prevent any conflicts. Now i did so much tests to find out whats wrong even the pigtronix hotline could not solve my problem. I think there is something wrong with that device and i decided to send it back to my dealer. Anyway, i want to thank all the guys that tried to help me!


We’re re, I just got my BB and Infinity Looper hooked up today and I’m having the same issue you describe above. Did it ever get resolved? I’m totally bummed out.

@Jacques60… don’t connect anything to the Infinity and let us know if you can record and playback phrases without the pitch/tempo of the phrase changing.

If you connect the BB and stuff starts going wonky, take a look at how the BB is connected. Are you connecting both the MIDI IN and OUT?

i dont hve the infinity anymore because the problems could not solved.
Now im working with a boss looper without any midi sync. Its hard but it works mostly.


When you open the infinity application go into global mass settings and check your settings. I am at work right now so I am trying to picture it but I think you have to uncheck ignore midi messages. You can set the infinity to start as soon as the beatbuddy finished the count in or set it to start when you press record on the looper. Make sure you start playback by pressing the looper not the Beatbuddy. If you start it by pressing the beat buddy it may change the speed of your loop. I have had no issues with syncing up the 2. Let me know and when I get home I can post a pic of my settings.

Hi Guys, Thanks for chiming in. I’m not in a position to try suggestions at the moment but will first app - tomorrow. I’m also supposed to speak to Pigtronics team tomorrow. More to follow on results. It’s nice to know there are folks out there who have had success. I was worried…and perhaps still a little. More to follow.

Friendly follow up: Domestic chores kept me away from BB and Infinity looper yesterday but tinkered w/it today – It’s working fine now and I’m having a blast. What was wrong?. This is still theory at this point but 1) Check “Ignore MIDI Notes” in the App. This was a common issue I found in blogs. 2. Not sure how or when I did it, but from reading the Infinity Users Manual (which could use some serious editing) I believe I must have somehow tapped into the “Varispeed” menu. It mostly makes sense because the playback was definitely off pitch. What doesn’t precisely add up is the way the tempo behaved (it was off too). Anyway, after some noodling, it seems to be working fine. More noodling will reveal the staying power of this theoretical solution. Will advise if theory falls apart. Thanks for throwing a lifeline however. It really helped during panic-mode. Taking the time to post this / offer a life-line incase others need hope.

Hey Jacques, I have been trying to read about your issue I have the same kind of issue with my Infinity. I got it about a month ago to use with the BeatBuddy. Unfortunately I don’t have much time to play it as work and life is super busy. For some reason when using the BeatBuddy the Infinity will sometimes kick into this varispeed setting. I don’t know why and it’s definitely frustrating. I use the serial mode with one input, midi notes already turned off, beatbuddy midi into input #1. The Infinity might work a while, then out of the blue after I record a new pass it switches to some varispeed setting. There’s no rhyme or reason to it. I’ve tried to look into why as well, using the software and clicking off anything that says varispeed, but for some reason it has a mind of its own and will eventually goto varispeed. When this happens I reboot the Infinity, but it doesn’t always fix the issue. It’s just bizarre. Let me know if you’re still “free and clear” of the problem. I definitely am not as it resurfaces every so often. Would be nice for a future update to completely disable this function if the user doesn’t want it. I surely don’t!

1 Like