BeatBuddy Manager 1.50 (Windows/Mac)

#1

Edited.

NEW VERSION. PLEASE VISIT: http://mybeatbuddy.com/forum/index.php?threads/beatbuddy-manager-1-50-1-windows-mac.4382/

#2

Got a crash using the Mac version. Was inserting a midi into a Main Loop.

[Mod Edit: Bug is fixed, new version is pending to be uploaded, huge thanks for the stack trace that is now stripped]

#3

It is not a legal midi, as the clip has 553 note-ons. I attached it so you can test.

#4

the version of this file is not compatible with the version of windows you are running this is what i get when i installed the bb vers1.5 exe i had no such problem with version 1.4 so im assuming this is a 64 bit version that i will test on my other computer
or is it a BUG …this is on windows … this a 64 bit window version it installed ok…but it only goes to C drive pls give us the option to install on different drives

#5

Only Windows x64 system is supported currently. An x86 build is still in the process.

I am quite sure an installer allows you to setup where the software is installed.

#6

@aashideacon We believe we have fixed this bug. Pplease uninstall your BB Manager, download it again from the link in the original post and reinstall.

#7

Hi
On mac
In finder / applications / BBManager .app. get info says 1.4.0, after half hr search and reinstall realise that it is 1.5.0.
Also probably pilot error but in previous when editing project in BBManager, once loaded from SD card i could edit off line so to speak, now i have to have SD card inserted into reader to edit project otherwise i get this . see attached
Thanks Ronny

#8

that worked. i get the proper “too many notes” error now.

#9

Simply answer Yes when asked to save a local copy of the SD card. Earlier version did this implicitly, and this was not so obvious that after you loaded the project you have two copies of the project.

#10

Hey guys, all my song data is not showing up in the new BBManager. All my personal projects/songs… the folders and files are still there, but nothing is in the left pane. I had mentioned on the last release that it was hiding my personal project folder in Explorer, but I was still able to use it in BBMgr. I pointed to my workspace folder, but it still doesn’t see it. I am not able to use this now and I need it to work.

Please help…

All I see is your start page.

#11

What I did was open 1.4, and synchronize everything to my pedal (sd card), closed it, then opened 1.5, and imported it all. It seemed to actually copy all the stuff from the pedal back into a new workspace.

#12

For one, I didn’t separate the installs to have both, and two, I don’t see why I should have to step through those kind of hoops to have an updated version of the same software recognize anything I created in previous versions. I should just be able to open it up and continue working. I am not able to do that… can you please look into it? Thanks.

#13

You shouldn’t have to jump through those hoops (and I’m sure there’s a “proper” way), but I couldn’t remember where my local library really was. In my early days, in learning about the thing, I ended up several different copies of workspaces and projects, until I figured everything out. When it took me more than 5 minutes to find my stuff, I just went back and did what I described above, cause I knew it’d be the fastest way to finish. I don’t work here–just a fan and user :slight_smile:

#14

You can go byPlug your BB to USB (or use Card)- File-Open Project-then find device for BB (SD Card (my PC shows drive “E:”)) Now you can open Project, then you have to save it to your PC and BBM will ask you for future sync…
Hope that was your question?

#15

Did you read it? Our best people worked hard to make sure you have the most helpful information available to you in this “cheat sheet” start page screen! Most likely there is a point missing about what to do if you already have the project from the older version. Thanks for the feedback, I will pass it along!

When you see this start page, you have no project opened. This means you need to open a project. To open a project, you use File > Open Project. Yes, that’s really that simple. No more importing / exporting / opening single file archive / etc - it’s all consolidated now in one File > Open Project action.

You have correctly setup your Workspace.
Now simply open your old project via File > Open Project and you will be ready to continue your work.

#16

i can’t import Songs or drumset from the pedal to manager , i look at the film but IT did not work

#17

Thanks for the response. I know exactly where my BBWorkspace is. I tried a couple of quick things but to no avail at this time. I’ll dig into it more today.

#18

Yeah, I know I can do that, but my files (the very ones that are on my device), are still exactly where they have always been for any version of the BBMgr. I don’t understand why 1.5 doesn’t see that and maintain what was already existing; even after I point to the exact same location per the instructions.

#19

Yes, I did read it… more than once. I closed the app and open it more than once, tried to point it to my BBWorkspace more than once. Even tried to open a project but the option was grayed out and unavailable.

That was last night. This morning after my computer restarted, and after reading a couple of the responses to my post, I opened it up again and it prompted me, again, for my Workspace, which I pointed it to, again, and then I was able to go to Open Project and get my project to open.

So, it looks like it resolved itself. Not sure if something had to happen for the reboot, or perhaps a logout/login would have worked to refresh the registry… anyway, I think I can move forward now.

Thanks!

#20

@mozobuddy Glad you have this sorted out, but actually having Open Project grayed out screams impossible to me. This must never happen, and I am unable to reproduce the issue locally.

The registry path have changed, as 1.4.0 was x86 (32-bit), and 1.5.0 is x64 (64-bit).

Your old settings are stored inside Wow6432Node:
[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Singular Sound\BBManager]

Your new settings will be stored in “normal” location:
[HKEY_LOCAL_MACHINE\Software\Singular Sound\BeatBuddy Manager]

(Sometimes it can be inside HKEY_CURRENT_USER instead of HKEY_LOCAL_MACHINE, for example, if you didn’t install the BBManager and simply copied all the files from the other machine it was installed at and run it).

When preparing the 1.5.0 version I’ve forgot about registry settings migration. I’ll see what can be done to fix this.