Cannot update firmware from 1.2.9 to 2.04

Hi all, I cannot update my BB from 1.2.9 to the latest firmware version
This what I have tried so far;
[]downloaded firmware version 2.04 onto the SD card, put the card back into the BB, powered up but the BB does not go into update mode.
]tried the same process with firmware version 1.8.5, but it still does not read the update.
[]created a downloaded a ‘back up’ from the website and copied this onto a ‘new’ card (formatted: MS-DOS (FAT32)) and added firmware 2.04
]removed 2.04 from newly created SD card and replaced it with 1.8.5
The BB just loads up the first song. I check the firmware and it reads 1.2.9. I am not sure how old this BB is , could it be too old to update? Surely not?
Thanks in advance

No need for the SN just yet.

Make sure that the SD card is not locked (slider on the side of the card).

Use your computer SD slot reader and not the USB cable to try and copy the firmware files to your card.

Hi, thanks for the swift reply!
SD card is not locked and SD slot reader was used to copy the firmware files.

You unzipped the file you downloaded, right? It should consist of 5 files.

It unzipped and there were 5 files (app, app.bin, boot.bin MLO, MLO.bin), I then copied the folder containing the files on to the SD card, deleted the previous firmware version folder.

The five files should be copied to the root or top level of the card. If this still doesn’t work, can I get a screen shot of the contents of your SD card, please?

Solved!:wink: I originally put them all in a single folder to the top level of the card :frowning: rather than as individual files.
I now have copied them as individual files, put in the SD card, powered up, up dated and all working.

Thanks so much for the quick and very helpful solution.