Can't Update Standard Pro Drumset

Finally had some time to update the Beat Buddy. I’m trying to update the Standard Pro Drumset v1.1.

I’ve deleted the former Standard Pro Drumset
Went to the new one “Standard_Pro_Drumset-v1.1.drm”
Click on Import Drum set but it doesn’t show up as being added.
Would love some help on this!

I think I found my mistake. When I was asked: “Do you also want to delete drumset from current project?”, clicked No. I should have clicked Yes.
Is there any way to fix this?

I seem to remember having to import and then make available. Search the forum here, but I seem to temember having to check the box or double-click the name of the drumset in the lower-left window where BBM lists the available drumsets.

Working from memory, so YMMVW (your mileage may vary wildly).


Thanks - I did that. It doesn’t show up within the Drum Set box.

I also reinstalled the Standard Pro drum set (not the latest). Followed through with deleting the kit and the drumset from the current project. No luck there.

Went through and changed the default for all the Standard Pros to something else. Still no luck.

I’m wondering if the file d/l from Singular is the problem.

Well…all’s well that ends well.
Restart the computer. Tried things again an hour later. Everything worked fine.

Sometimes you just have to give the computer a swift smack. Show it who’s boss.


(But I’m glad it worked out!)