Footswitch question

My left footswitch button has stopped functioning. I ran the detector. It says “momentary”. When I click “Enable”, the assigning functions(1st switch stopped, 1st switch playing) get grayed out, and the left switch will play a fill. When I select “Disable”, then the assigning functions are configurable(this seems backwards to me?), but the left switch won’t do anything at all.

Any suggestions would be appreciated…

Make sure that you are using a TSR cable and that it’s not defective.

I am using the included stereo cable and have also switched to another stereo cable just to check that component and it does exactly the same thing with both cables.

Open the remote foot switch and check that there is no disconnected wiring inside the enclosure. Insert the cable while it’s still open and check that the jack is making firm contact. You could try opening the pedal and checking the same things but if you’re still under warranty, it would probably be better to contact support@singularsound.com before you do.

Revert to a previous version of the firmware and run the detector again on the pedal.

Verisimo,
Using either or of your TRS cables, plug one end into the BB. To the other end using a piece of wire or something like a metal paperclip, bridge the sleeve of the TRS plug to either the ring or the tip to see if the BB pedal responds. Bridging the sleeve to the tip should act like the right button on the footswitch and bridging the sleeve to the ring like the left button. If this simple test works with either cable you’ll know the BB pedal is OK and the problem is likely the button switch in the footswitch.
It may be possible to squirt some contact cleaner into the side of the switch from the topside to get the switch working again. (recommend DeOxit contact cleaner if you can get it)

1 Like

Persist, thank you. The unit is almost brand new so I will definitely contact support before I try opening anything up.

And Mark48, thank you for the in depth response and taking the time to make a clear drawing. Sounds like a great way to eliminate a possibility. I’ll try it later today.

Can either(any) of you tell me when you click “Enable” on the 1st footswitch button if that grays out the configurable options on your bb? Or is that indeed backwards from what it should be?

1 Like

If you are referring to the 1st Main Pedal, I can verify that what you are seeing is the correct behavior.

Solved… Maybe?

I went to-- settings / Footswitch / Accent Hit / Source

And changed from Default, to Global, and selected a sound from the library and it’s working as normal, now.

I’m not sure why the default doesn’t have a sound attached to it, but it apparently doesn’t.

2 Likes

Actually, I came here because I had the same issue. Got my beatbuddy on Friday and upon connecting the footswitch I experienced the same thing you did - accents did not work when “Default” was selected. Like you, I had to select a Global accent, which although is a workaround, it seems like it should not have to function that way. Does anyone out there know how to select a Default accent for each kit? It’s in the menu, so it should be able to function somehow I would think.

Yeah I wonder if maybe something got changed in an update?