Footswitch song advance function broken after firmware 1.8.5 update

Touching the footswitch once advances the song as normal. Further touches do not advance the song, but open the song folder instead.

Prior to updating the firmware, the song advance worked perfectly.
After updating the firmware, I immediately went to the footswitch settings to set switch 1’s “stopped” behavior to Song Back and switch 2’s “stopped” behavior to Song Advance.
Testing it yielded the above behavior.

I restored the footswitch settings to what they had been before the upgrade: 1 - Accent Hit, 2 - Song Advance. Behavior continued as above.
I disconnected the BeatBuddy, waited a few seconds, plugged it back in, and tried again. Behavior continued as above.

I can provide a video of the behavior if needed.

you need to upgrade your pedal to momentary switches …
happened to me also, until the upgrades …minor solder, BB offered a rebate.

Thanks for the reply @rknrne. I have a BB-branded footswitch, so I’d be surprised if a firmware update actually broke BB’s own hardware. Has a need for upgrading to momentary switches been documented anywhere? Anyway, your comment led me to do a search in the Tech Support forum for momentary switches, and I found this recent thread:

I’ll try running the footswitch detector and see what happens. Hopefully that’ll fix it - changing the switches may be simple, but I don’t have a soldering iron or a couple of momentary switches just laying around, and I need the pedal to work for a gig this weekend o_O

worked for me. my problem is …
I use 2 sd cards & interchange them when @ the gig…revising, ediiting, uploading new songs ,
I have to always reset my [footswitch functions] to make the outro happen on 2nd pedal playing,
[cue fill] reset to 50% , &[ release time] to 60? catch the fills & outro towards the end of the beat.
…I’m waiting for them to re-release the export back to pedal …which would solve this issue!

Running the footswitch detector did indeed resolve this issue. Cheers!

I just received my BB & BB foot switch yesterday. I uploaded the current firmware - 1.8.5. Ran switch detector & followed instructions. BB screen said “Press and release left footswitch.” I did & nothing happened. Just to see what would happen, I pressed the right footswitch. The screen then said “Press and release right footswitch.” Then it said “No right pedal detected.” Then it gave a status off: Momentary & Normally Off.
I tried a known good TRS cable and it didn’t help. I tried various sequences of powering on, with pedal attached, without pedal attached, etc. still no joy. I also tried a factory reset on the BB. Looking at the footswitch programming options they show: FS type: Momentary, FS order: Enable, FS Polarity: Off. The only think that happened with the BB FS is the left switch triggers an accent hit and the right does nothing. I did a factory reset again and nothing.
I tried a Fender dual momentary FS and the left switch did stop and start it, but the right switch did nothing.
Is the problem the BB or the FS???

I just tried my DigitTech FS3X footswitch, with a TRS cable. The 1st & 2nd switches (of 3) work as designed - 1 (left) pauses/starts; 2 (right or middle on the FS3X) triggers an accent hit. The 3rd (far right) switch makes both happen! Pause & accent. Another click on the 3rd switch starts with an accent ! I may just use this all the time and return the BB switch! The pause & accent work nice when you don’t want the longish outro beats to end a song. :wink:
The FS3X is $40 on Amazon with free Prime shipping.

this happened to me last night … song advanced …took my eyes off for a sec …
& it went to country folder, scrolling thru the folders , but, I couldn’t get out of country…
took a few chances left , right, …finally got out by holding both buttons on the BB. it returned to ‘my sets’
Whew! …
’ I’d be surprised if a firmware update actually broke BB’s own hardware.’
I think they( BB) were also, which is why they offered the rebates. :wink:

I also thought the folder navigation got broken in the 1.8.5 update but I was able to figure it out. Holding both footswitches down takes you to the internals of the current folder. Holding one footswitch down takes you to the folder navigation menu. It appears everything still works but it’s a little convoluted.

I’m getting a no right pedal detected also. What is the solution?

Have you by chance switched the cables? This happens if a mono cable is used. Make sure you are using a TRS cable (two circles on the metallic portion of the cable) and not a mono cable (one circle). If you are using a TRS cable, try a different TRS cable as the first one may be defective. If this doesn’t solve it, please email us at