How can I use Beatbuddy only as MIDI tone module ?

I was wondering how can I use Beatbuddy only as MIDI tone module, so loops are disabled.

I’d like to just have the drums Midi mapped on my keyboard to sequence on my own instead of triggering the typical loops. This is done via note on/note off Midi messages I believe. Thanks !

From this PDF (a bit older firmware version, but likely close enough)…
https://singularsound.com/downloadable/BeatBuddy-MIDISettings-Firmware-v1.77.pdf

‘3. Trigger the BeatBuddy’s super awesome drum sounds with an
electronic drum set: So you have a cheap electronic drum set and you
hate the way it sounds. You can connect the MIDI OUT from the drum
set to the MIDI IN on the BeatBuddy and when you play on the electronic
drum set, it will play the BeatBuddy’s award winning super high quality
sounds! This is also useful when you’re composing beats in your DAW
and want to test how they will sound on the BeatBuddy – no need to
load the MIDI files to into the BeatBuddy – just stream the MIDI notes!’

So does this mean I would remove the SD card ? Just trying to figure out how to do it without starting the Beatbuddys looper. I imagine must be a way to disable the looper maybe.

Nope, leave the SD card in. You are aware you need the MIDI adapter cable, correct?
I just tried this with my Roland DR-880 MIDI’d into the BeatBuddy. If I start the DR-880 pattern it will start the BeatBuddy, but just tapping on the pads of the DR-880 triggers the sounds of the BeatBuddy, which is basically what you want to do. Pretty straight forward, but again you’ll need the MIDI adapter cable to connect up

yes, I have the adaptor. But that’s the thing, I don’t want the Beatbuddy to start. Just want to use it as a tone module. (trigger midi notes/sounds externally).

Plug it in and try it. It won’t blowup :wink:

Yep that’s what I’ve been doing

I think I may have misunderstood your question. I was thinking you were just hitting keys/pads to trigger the BB, but reading your post again it sounds as if you have a workstation with an onboard sequencer that you are sending to the BB. Is that correct? If that’s so just disable sync, start, and stop and keep note on and note off enabled in the BB settings as shown in the PDF I linked. Might be some other settings to look at as well, but that should prevent the BB from starting a loop.

Also remember that your midi source will be playing just the active kit in your B.B. Your midi controller will be capable of playing many notes thst are not mapped to anything in the B.B. So, it’s a real good idea to open up the BB drum kit in the drum kit editor window in the B.B. so that you know which midi notes are mapped to which drum tones.

What I do is to have a “blank” song loaded on the B.B. This consists of a B.B. song that just has a Null loop entered as its main loop. That way if it does accidentally get started, it still won’t play a track. Then just select the drum kit you want and your midi controller can play that kit, assuming you have the B.B settings all correct. You need to have midi in notes enabled.