I can't delete an empty drumset....

Somehow, when making a copy of the brushes drumset for editing (I did rename it), I wound up with a copy with nothing in it. It’s not a big deal, but just seeing it there bothers me. BBMGR won’t let me delete it, telling me it doesn’t exist.

Any ideas on how to get rid of it?

Before Deleting anything make sure you have gone into the drumsets dropdown and saved any modified drumsets to a hard drive somewhere.

To delete a drumset there must be no drumsets open for editing. In the dropdown for drumsets click close drumsets and editing options should disapear. Now you can select drumset to delete with one click and delete drumset option should be available in dropdown menu.

You can also get rid of the tick option this way.

I’ve done that…everything is closed. I can select the drumset name and the delete option is available, but then I get the error msg.

Well, this definitely looks like a bug.

If only I knew the exact steps how you got that. Can you please provide some screenshots of your “empty” drumset and the error message when you are trying to delete it?

By the way, I guess I know the not-so-easy way to fix your problem - open your project in Windows Explorer (or Mac Finder).

  1. Close the BBManager.
  2. Open DRUMSETS folder.
  3. Open CONFIG.CSV with any text editor:
  • For windows: press Win+R, type notepad, then drag’n’drop CONFIG.CSV to the opened window.
  • For Mac: right click the file, Open With > Other > Choose TextEdit in the opened window.
  1. Find the line with the name of the drumset you’re trying to remove.
  2. Delete that line, and disregard all the other content, it will fix itself.
  3. Save and close the file.
  4. Re-open the BBManager, your drumset should no longer be on the list.

The other thing to try would be to check the contents of your BBWorkspace/user_lib/drumsets/ folder to see if there are any 0 bytes .DRM files or something. Screenshots of this folder will definitely help.

away from computer today… But here’s what happened. I was adding tambourines to the brushes drum set
Made a copy of brushes
Renamed it brushes w tamb
Opened for editing
Renamed it on the editing screen
Added tambourine
Saved it
Somehow (sorry, no more details here) , I noticed a second copy Brushes w Tamb (1)
I was able to delete that ok, shut down BBMGR
Reopened it later, now had two Brushes w Tamb, one with checkbox on top of list, one on bottom of list, no checkbox
The one on bottom is empty, no name in the editor … Tried deleting, no go. Tried giving it a new name in the editor, saved… Tried deleting again… Nothing.
To me, it seems like a directory issue.