Main volume stuck at 0%

Hi there,
I have been having problems with the Main volume lately.
I am on Firmware 2.0.4-RC4
It started several day ago being stuck at 0% and when you turn the knob to the max it would go to 2% only.
Then I rebooted the firmware and when it finished with the upgrade started flickering between 64% and 66% and was doing that for 30 seconds and then started working normally again.
Today it is stuck and 0% and wouldn’t move.
Everything else seems to be working fine.
I tried:
Switching of for 20 min then powering up -same.
Reinstalling the firmware - no change.
Connecting it to the Beat Buddy manager 1.65 - same
I looked at the forum for previous threads and found one but the answer to that one didn’t solve my problem
No volume - No play

Can someone help, please

Please send an email to, this sounds like a hardware issue.

If you haven’t tried a new SD card, you might want to do so. If you don’t have or can’t get a new one, try deleting all of the files on the card and then reinstalling.

In the interim, you might be able to use the headphone jack output.