Newbie midi sync question BB/Looper/Onsong?

Still doesn’t work.

I’ll run through step by step what I’m doing, see if anyone can spot my error?

Firstly on my version of OnSong pressing & holding the name does nothing.
However I can get to midi events by pressing the pencil & going in to edit mode, then pressing the info (i) circle, scrolling down I find midi send & press that which takes me into midi events.
Pressing the + sign gets me into a new midi event.
I Have the options of
Type, I choose program
Channel (I’ve tried with 0 & 1 with no luck on either)
Program, (I’ve tried like the example in the PDF, honky tonk piano?)
Bank MSB 0
Bank LSB 0

The metadata in edit mode then reads
MIDI: 0.0.3@1

I thought that adding the curly brackets to this metadata would help but it makes no difference.

In my case, the metadata for the first song in my 10th folder is: 0.9:0 where the 9 represents the folder and the 0 after the colon represents the 1st song in that folder.

MIDI: 0.9:0

@braziliansway I don’t know if you already visited the Onsong page where you can check many tutorial videos they’ve been publishing for many years. If you haven’t, here are a few of them which are pertinent to your situation. I hope they shed some light:

Onsong Tutorials:

Converting PDF to Text:

Controlling Beatbuddy with Onsong:

Control Your MIDI Rig Wirelessly With CME WIDI Products:

PS: have you tried reversing the WIDI Master connectors? It’s very easy to connect them the wrong way round.
Also, this: “Firstly on my version of OnSong pressing & holding the name does nothing.” only works for Text songs, not on PDF ones.