No License and intermittent sound.


I just got my beat buddy. However when I plugged it in (inserted the SD card first) I get a big “NO LICENSE” displayed at the top of the main screen and the drum beat sound is intermittent.

Do I need to activate the license first? Because I can’t find anything about license in the manual.

Thanks a lot!

Do the following steps, and please report if it helped.

  1. Connect your BeatBuddy to the computer, or (even better) insert your BeatBuddy SD card into your card reader directly.
  2. Carefully copy all the files and directories in SD card to somewhere to your computer. Note to check “Show hidden files and folders”.
  3. Double check that you’ve copied all the files and directories from SD card to somewhere on your computer in step 2.
  4. Download new SD card content from … .rar?dl=11
  5. Erase all the data from SD card.
  6. Unzip all the file content downloaded from step 4 to the SD card.
  7. Unplug BeatBuddy from computer or insert SD card to the BeatBuddy.
  8. Power on your BeatBuddy.
  9. If “NO LICENSE” crap persists AND you possibly have another SD card, try repeat steps 5-8 with your other SD card.
  10. If the problem sticks, immediately contact support at ! BeatBuddy should have worked at this point already…

Even if it worked, please archive your files from SD card, and upload them to somewhere for me to check them, if you can. Thanks!

This is a special case – I know what is wrong. The factory accidentally did not load the firmware license on your unit.

  1. Press the tempo and drum set knob at the same time.
  2. Go to ‘About BeatBuddy’.
  3. Write down the ID number.
  4. Please email the number to
  5. We will send you some files to put on your SD card that will solve the problem.

Sorry for the hassle!

1 Like

He there… I do have the same problem with my BeatBuddy. I too sent my ID to technical support and am currently waiting for a positiv respond. By the way, did the files that you received from tech-support work on your BeatBuddy?

Same here. Just mailed David to help me with that :frowning:

I have the same issue except my started with no sound just just the display would blink on and off and it said Production at the top. I updated the firmware and now i have No Licenses displayed and when I try to use the Beat Buddy the sound is intermittent. It is stating and stopping in cycles. :frowning:

my new Beatbuddy arrived today. Unboxing…connecting cables…insert SD card…power on.
Display says “NO LICENSE” and sound is intermittent. I sent David a email and hope he can help me.

Update: Thanks for helping :slight_smile: My BeatBuddy now works fine

Hi I got the same problem.


Hi my BB doesnot work well

I think you’d have a better response if you create a new topic and describe the issues you’re having. The community and support can then weigh in and help you. It may be something we’ve seen before

BB show No license on the top off the screen and sound it’s cut beat by beat

Hi my BB show No license on the Screen.

could you please help me to solve.

thank you

The solution is to email support directly

in my BB J I dont see the aboutBeatbuddy

Just email