No Sound When Beat Plays

I have watched the video’s, read the literature, read the forum and searched the forum and can’t find an answer. I purchased a 4gb SDHC card, created a new project, imported sng files, exported and sync’d to the SD card. I inserted the card into BB and it plays normal just like the one that came with it, except NO SOUND.

Can anyone tell what I did wrong. I upgraded the firm ware to 1.4.1 and still no luck. I made a set list SD a couple days ago that played for a couple times, then it quit working.
This is definitely not a user friendly product.

Does the original SD card work? I assume it all works in the manager software. Which outputs are you using, have you checked the headphone volume? If you have an external pedal attached can you tigger any accent hits?

Yes the original works, the cymbals work. Headphone volume off. I copied the original SD card onto the new card, then exported the set list project from the manager software to the card and selected overwrite. I have the set list working now, but the original drum sets were overwritten. Anyway it works now. I am hoping now that the card is sync’d I can just add more beats to the list by exporting the song. Thanks for responding.

I am having the same issue. I have had a BB since December and have loaded several beats. I haven’t loaded any new ones in awhile until Friday. This is when my issues began. It will seemingly play in the BB (you see lights and the tempo across the screen) but there is no sound. I also notice that each song does not “load” as it previously would, and I have no drum sets on my pedal.
We have erased the SD and reformatted with the SD link and the firmware on here. When this is done, the original content plays on the pedal fine. But when I try to upload my previous pedal, I get the above issues every time.
Please help! My husband is better at tech stuff and he has read everything in the forum and tried everything.

When you set both volume dials (the knob on top and the headphone volume wheel on the side) all the way up, still no sound? Also, look in the BeatBuddy Manager. On the ‘drum sets’ tab, are all the drum sets checked? Or are the tick boxes unchecked? Make sure that they are all ticked. Then export to pedal.

Still no sound. We’ve tried everything with the knobs.
And yes all the drum sets are checked in the manager. :confused:
Any other suggestions we might could try?

If your unit loads the song, but no drum sets exist, that would mean that somehow they got deleted from the SD card. If in the Manager, all drum sets are checked, then do File > Export > Project to SD Card - does it still not produce volume?

If not, I would try it on a pair of headphones, because maybe the cables themselves are bad, or the setup, somehow, is bad.

If still there are issues, I would be happy to take a look at it and fix the BeatBuddy, or replace it, if need be. If despite the two above solutions it still persists, email us at support@mybeatbuddy.com - and I will provide instructions on how to send it back for repair.

That is my thought too that somehow the drums are getting deleted off the card. It is not an issue with the BB because I actually have two of them ( I purchased a back up a few months ago after having an issue) And it does the same for both of my pedals. I have tried several different cords, and 3 pa’s.
Trying it through headphones does not produce sound either. There is something that gets messed up when I try to sync it with what’s in the BBManager. I just haven’t been able to figure out what it is

I found that was my problem is that when I exported the project to the SD card I did’t have the drum sets ticked. So the sng file was playing fine, but didn’t know what to do with the sound because there were no drum sets exported with it. I would suggest keeping the original SD as original and work with a copy SD card. Create a work file on your manager/hard drive. When you send the project to the SD card make sure the drum sets are ticked. Send project to SD and click OK on overwrite. Then sync card to manager. The only issue I had was that after my original set list was on the SD card I continued building additional songs with the manager. When imported into the set list on hard drive they didn’t keep their name. Before I sent them to the SD card I had to rename them. Everything is working fine now. There is a learning curve with this software. I haven’t figured out everything yet, but it is working and I love practicing with this unit.

I’ve tried this several times as well. I overwrite it and try to sync it but I get an error message that tells me “unexpected error occurred while linking project. Project synchronization will not be available yet. Use file<export<project SD card instead.” But that’s exactly what I did when this message popped up. Very frustrating.

Just by chance do you have the security tab opened so the SD card can accept files? Looking at the face of the SD, the tab is on the left side. Up is open and down is locked. Just a thought, like checking the gas. Maybe manger can send to the card?

It wasn’t the card. But THANK YOU to BB Support (Jay) for helping me get it solved today. If you have any issues, he’s the man. Very easy to work with!

As you were having so many issues what was the fix…it may help others.

I made the correction when I exported to SD by making sure the drum sets were checked in the drum sets tab for export. Export then sync. I had previously exported the sng files and they played, but without the drum sets it was like playing “air drums”. It was going through the motions, but no sound.

I honestly don’t know how Jay (support guy) fixed it. We were having a phone conversation while he remotely accessed my PC. He tried a couple things before it worked correctly. I wish I could be more help!

If I recall correctly, we downloaded ‘SD Card Backup’, and we replaced the files on the SD card, re-imported the project into the BBManager, and linked that project as the main one. Most likely corrupt files.

Whenever unexplainable behavior happens, I always take into consideration that the files or the SD card itself may be somehow corrupted. Replacing the files and/or SD card is the surest way to know.