Recording delayed by 4 beats ever since updating to 4.2.4

Hi I use ableton as master clock and a midi solution splitter to send that clock signal to a headrush looper board and the aeros loop studio. It used to work just fine until yesterday when I decided to update to firmware 4.2.4.

Midi sync is showing as ‘‘on’’ in the Aeros but when I click ‘‘record’’ it waits 4 beats and then starts to record…I’ve tried changing the time signatures, sending the midi clock through my Headrush Looperboard to no avail…the weird thing is when I restart the Aeros it seems to fix it temporarily but when I cue another tune in ableton (with a different tempo but same time signature) the delay returns…We have an important showcase on saturday so I’m gonna revert back to 3.5.1 but I would love to understand what is going on here!

Any help is greatly appreciated :slight_smile:

Found a way to fix it!
Instead of sending the clock from Ableton to the Headrush and to the Aeros I’ve switched it around so that the Ableton clock goes to the Aeros and thru to the Headrush…

Turns out enabling ‘‘midi start - PLAYBACK’’ on the Aeros fixed the delay problem and really helps the Headrush to get good clock too.

Hope this can help anyone else with the same issue.

Hey there,

Thanks for reporting, to help diagnose your other issue you reported to me, it would be helpful to know the following things:

When you say cue, do you mean a scene? Or are you saying opening a new project?

Does your Ableton project have a set tempo, or is it fluctuating? What is the tempo?

The Aeros can only change tempos if the Aeros is empty, it does not re-quantize audio to new tempos. Songs can only be recorded to and played back in one tempo. If you are changing tempos without stopping the Aeros, it is possible it has not fully adapted to the new tempo even if empty, this causes a desync. The best thing to do if changing tempos currently is to clear the song on Aeros after a tune, verify the tempo is matched and start Aeros using a MIDI Start command.

Let me know thanks, if you can DM me a video of what you are doing I can possibly further diagnose!

Multi-tempo support (one per song part) within a single song is something we hope to have working soon, so this may change.

Thanks again for reporting :slight_smile:

1 Like

Hi Brennan,
Yes it is cueing a scene on the grid of ableton in the same project. Our scene change for our show activate parameters in the project such as tempo and time signature and the Aeros is being cleared of everything before my collegue triggers the next scene. Everytime a new scene is triggered the Aeros responds by starting playback bang on with the new tempo information, therefore I doubt this is an issue with ableton sending clock data but an issue with the Aeros’ behaviour once the clock data is received ( it seems). Ableton’s Tempo never fluctuates (once it is set) but in our project (which is our show’s setlist) the different scene range from 80 to 160 Bpm. We have a practice on Wednesday and I will make a video so you can see what it’s doing.


Hey! We never heard back from you! I do wonder if beta 5.0.x improves your experience…

Let me know if you’re still using the Aeros or if you maybe solved the issue!