Rename Drumset Trouble

I got an email telling me content was updated and I needed to rename my drumsets to remove the version number, e.g. 1.1

When I change my Brushes set, it renames it to Brushes(1) because there is already a Brushes in a second list below my drumset list. That seconds list has no check boxes and the names are in Italics.
It says “Drumset local to the project”, whatever that means, and says “uncheck to remove from project” but there is no checkbox (and I’m not sure what it’s going to break if I remove it from the “project”

Yeah, I found the version number thing confusing. The ‘original’ drumset that came with my BB had no suffix version numbers. They created a new drumset which then had suffix 1.1 following the drumset name and these drums appeared to get properly assigned to respective beats in BBM. Recently I found a newer version, downloaded it, and loaded it into BBM. This recent ‘new’ version now has no suffix number which I was expecting to be maybe 1.2. At that point I’m thinking the drumset got regressed to the old original version, but I did find a note that the dropping of the version number was intentional.
Now I’m in a quandary as to how I keep track of different versions of the drumsets since there may be no version number or if I even need to.

well the email I got said they are getting rid of the version number in the name, so I think you are OK, but how did you get the new version to import without the (1) after it?

I imported the whole ‘enchilada’ as the ‘Default Beatbuddy Content Update’ from…

From that link it’s shown the drumsets are v1.2, but once loaded there is no way of knowing.

Just tried something… wtf…
My new version 1.2 drumsets are in italics. 'voice was in italics. I opened it in the editor to see if some reference to v1.2 might be there. Nope, so closed it without a save and it had a checkbox next to it. Closed BBM and reopened and now ‘voice’ is renamed ‘voice(1)’. This is likely somehow relate to how you have the (1) after your drumsets.


today I figure out that after the drumset is renamed Brushes(1), I can edit it again to remove the (1), so it works as a 2 step process. I wonder why nobody else is reporting this though.

I upgraded to 1.6.5 this morning but I don’t know that it has anything to do with my ability to fix it, I just hadn’t tried re-editing it yesterday

actually, now I am really confused. the reason it seemed to work is because Brushes was no longer at the bottom in italics, so it let me rename it.
Metal on the other hand is still in italics at the bottom and I can’t rename it

MArk, I’m guessing you have Voice in italics in yours (can’t tell from the screenshot)

I don’t understand what the list in italics at the bottom are (default drumsets that were never loaded through BM?)