Switches fail to program properly - both left and right act as single switch

New BeatBuddy, installed latest firmware. Installed BeatBuddy brand extension switches, pressed both drumset & tempo buttons, told it to discover the footswitch— and first it thinks the thing is latching… you gotta be REALLY QUICK to get it to sense it’s not a latching switch… but it goes from “Left” to “done”… never asks about the right switch.

I manually set what the switches should do, but no joy.

Do I have to revert to an old Firmware to set the switches?

Manual work-arounds?

Are you using a TRS cable between the BB and the foot switch?

Yes - BeatBuddy factory brand… came with the pedal.

Triple checked it was in all the way on both ends, too.

To rule out the possibility of a defective cable, you could try substituting it for a known good TRS cable and trying again. If that doesn’t work, it might be best to contact @BeatBuddy Support

I can try that once I’m back home, but there’s no way I can imagine that a defective cable could make the unit think a momentary switch is a latching switch… Has anyone else on the forum set up the switches after the firmware update? As an electronics & computer engineer, I get the feeling the debounce routine is going haywire - it’s like the timing of the sense loop is too fast… 1/2 second is way too short to decide that the switch has latched.

Feedback for continuous improvement - make an option in the footswitch settings to force the proper values for the factory switch.

Which version of the f/w are you using? Most user problems with the foot switch have not been firmware-related (they’ve either had a defective/wrong/not fully seated cable or possibly even a bad foot switch). You could try reverting to a previous f/w version and try again. Or, if you have another foot switch, you could try that too. You could also open up your foot switch and check the switches individually.

If none of these are the source of the problem, then it could be either your BB pedal or foot switch–in which case you will need to work with the vendor you bought it from or BeatBuddy Support to get it resolved.

Good luck. You’ll get it all sorted out soon enough.

Firmware 1.40 (the newest release as of yesterday)

Will try a different switch & cable tonight - if that works or doesn’t, we’ll know which end holds the problem…
Worst case I’ll go visit my pal with the working BeatBuddy and try his cable & outboard switch box.


Latest f/w release version is 1.41

Check. Thanks.
It’s the version downloaded as ‘current’ yesterday - I’m not at home so I googled “beatbuddy firmware” - result showed 1.40… but it’s really whatever was posted on the site.

Glad to see another tech-savvy person on the forum!! I think later versions (in beta) had options to force the BB to specific footswitch settings, including latching vs non-latching. If you email the BB support guy, he’ll email you back the latest. There have definitely been updates to the footswitch functionality since 1.41. The beta firmware has been very stable for me.

Confirmed - it’s an issue with the BeatBuddy itself. Other switch box, other cable, manual switching on stereo cable… no joy… seemed to work for one or two cycles then back with the odd behavior.

Sent support an email - either need to revert firmware, try beta firmware or exchange the unit. We shall see!

One more thing to try, rebuild the project on your sd card onto a clean SD card

@persist Thank you for tagging me.

@rmesic I have answered your email, but I would like to answer here as well so everyone can see the response just in case there may be somebody else who might experience this issue:

If both buttons are sending signals out, then both buttons are detected - so at least we know that it is not a defective cable. :slight_smile:

Of course, just make sure that you are indeed using a TRS cable, i.e. two circles on the metallic portion of the cable.

When you press your footswitch buttons, does it make a ‘clicking’ sound, or is it a smooth feel pressing the buttons?

Go into your settings menu (press the ‘tempo’ and ‘drumset’ knobs down at the same time), and then go into Footswitch > Footswitch Functions. Look into 1st/2nd Switch Stopped/Playing (four separate menu options). See if somehow by chance the functions are just configured that way and need to be changed. If this is the case, then the solution would be to simply change the settings.

If however, they are configured differently than the behavior you are experience, I would like to inspect the footswitch and the BeatBuddy, as it is likely that one of them is defective.

Let me know what happens. Thank you.

Per my reply email (just to share with the forum):

It’s the actual BeatBuddy brand extension switch and cable - truly stereo cable, momentary switches.

I tried it last night with a Lexicon brand dual momentary switch and the BeatBuddy cable - same problem. Then I took an insert cable (stereo on one end, two mono on the other) and manually shorted the plug contacts to “switch”… same problem.

I actually followed the directions on how to set up the switch for initial use, I can correct it from “latching” to momentary, but can’t make it believe there are two switches. When I do manage to get it to sort of work - it only works as intended for a couple (less than six) switch presses before it starts seeing each switch as both again.

So - pretty confident it’s in the unit.

Do I need to ship it back or is there a firmware / system reset I can try first?
I did the “restore” under the footswitch menu already - no joy.

Harrumph. Met with another owner, swapped parts… Think there might be something wrong with two of my cables - both the patch cable that came with the switch and my break-out cable.

We didn’t do the pedal set-up - but just plugging in his switch worked as expected. Plugging my switch into his had same failure. Switching the cables moved the problem…

So - pretty sure it’s a spotty cable.

Contacted Sweetwater about replacement… thanks group!