I am finding that the Synchronize item is greyed-out in the File menu. I have a local copy on my computer which, I assume, is being used when my BB is not attached. I found the solution to Export the project to the Beat Buddy and then it asks me if I want to remember that location for future synchronization and I click yes - but it doesn’t remember, I have to Export every time. What am I doing wrong?

Don’t know. Which version #s of the BBM and firmware are you using? Please don’t say “the latest” as that’s not helpful :confused:
This problem could usually—but not always be caused by using your Mac OS to perform file operations that should be performed by the BBM, which has it’s own file management structure. Other times it might be caused by not using the BBM to set your bbworkspace location.
I’m using Sierra and I think it has its own issues with the BBM. and 1.8.5. I am using Sierra 10.12.2. I set my bbworkspace inside my Documents folder. It would seem that BBM is not remembering the BeatBuddy SD card path – /Volumes/BB0

Not sure but it looks like you’re not saving to the top level of your card

Here is a screen shot of the card from my BeatBuddy. Does this look right?

It looks right.

I have the same problem with Sierra but not with the previous version of the OS (10.11.2). I have to export instead of synchronizing in Sierra. I’ve provided feedback to the Apple development team. It worked in the earlier beta versions of Sierra . . . .

I’m having the same problem with my iMac running Sierra 10.12.2. Synchronize Project is greyed out when working with previously linked projects. I also have a MacBook Air running El Capitan and a Win7 laptop, and they don’t have this issue.

I’m using iMac Sierra 10.12.5 and also having exact same problem. It only recently started. I’ve tried everything I can think of but it just won’t sync. Have to export project every time. A bit of a pain. Hoping they come up with a solution soon.

A potential workaround when Sync Project is greyed out in the BBM:

  • try restarting your Mac and in BBM, Export Project; this usually works after 2-3 times
  • once the BBM Synchronize menu entry becomes active, try to avoid putting your Mac to sleep; allow it to time-out into sleep
  • once active, Sync often
  • do not quit BBM, leave it open
  • do not restart your Mac once it’s working

The developers are aware of this Sierra behavior.

I also just noticed that after exporting a project to the card, all the pedal settings revert to default so I have to reset them all to my preferences every time. They really need to fix this. I think I’ll try reverting to a previous version.

With respect, this is not really a practical solution IMHO. Once I revert to a previous version, I’ll let everyone know how that works.

Agreed however, by reverting to a previous version of the BBM, it becomes a tradeoff with the features that may or not be important to you. There’s a also a workaround to retain the pedal settings. You can PM me if you’re interested.

I actually reverted the firmware to 1.85, not BBM. It didn’t work. So, I take it we know that this is a BBM issue, not a firmware issue? Thanks for your help.

It is a BBM issue.

When will the new version of the BBM be released with a fix? I saw a release a month or two ago that had this fix in it (OSX synch) but then the BBM release got pulled because it was not stable or other errors. Everyone with OSC really needs this fix.