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GETTING STARTED (FIRST TIME)

Step 1: Installation

Please note that the BB Manager is only compatible with: Windows 
Vista or Mac OS X 10.9 or later.

The BBWorkspace directory (the folder where all BB Manager data 
is stored) MUST go in the ‘Documents’ directory. The Windows 
installation should put it there automatically, but in the Mac 
installation you must manually drag it there during the installation 
process, a window will pop up giving you that option.

After you have done the above process correctly, once you open the 
BBManager for the first time, you must select Tools > Set Workspace 
Location, then navigate to Documents/BBWorkspace, make sure 
that the folder ‘BBWorkspace’ is selected, and click ‘open’. It will 
ask you if you want to reset the last workspace location, click ‘yes’. 
This is mandatory, and the BBWorkspace directory MUST be in the 
‘Documents’ directory.

Step 2: After installation, you must create a project from the SD card

A “project” is all your songs, playlists, drumsets, etc. as one “unit”. 
You can have only one project on an SD card, and for 99.99% of all 
purposes you will only need one project.

Creating a project: Insert the SD card that came with your BeatBuddy 
into your computer and, in the BeatBuddy Manager, choose File > 
Open Project -- and select the drive that contains the SD card (it might 
say something like “removable drive” or something similar, in Mac it 
may say NO NAME), just the drive itself, not any of the folders within 

If you get a security prompt 
the first time you try to open 
the BBManager, right click on 
the icon and select ‘open’ (or 
press and hold the Control 
key while selecting Open). This 
may be required since it is a 
3rd party app not obtained 
through the App Store.

MAC SPECIFIC:

PART 1
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it, and click ‘open’. After the project loads, it will automatically prompt 
you to save a local copy on your computer. Click ‘yes’. After it finishes 
saving a local copy on your computer, which can take 2-3 minutes 
to complete, it will ask if you want to ’save the project for future 
synchronizations’ - choose ‘yes’ for this as well.

IMPORTANT NOTES (please read):

 1. You create a project ONCE (1st time you use the BBManager), 
and then after you go through the process of creating a project you 
will never need to touch the first 4 options under the menu option 
‘File’ again. If you do create additional projects or touch those top 4 
options under ‘File’, your computer may blow up! We’re kidding... but 
it’ll just be a pain in the asphalt.

 2. Bug specific to Mac OS X 10.12 or later: You will not be able to 
synchronize your project (the option is grayed out on the File menu). 
You will have to export it each time, which means overwriting the 
SD card with your current project. The export process resets the 
footswitch settings back to the factory default, so you will have to 
re-select your desired footswitch settings from the fooswitch settings 
menu in the BeatBuddy if you have changed them. We apologize for 
this bug, and we are working to fix it.

The BeatBuddy’s SD card slot 
is located at he top, next to the 
USB port.

SD CARD SLOT
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BASIC CONCEPTS/FAQS

What is a “project”? Should I create more than one if I 
have multiple gigs?

You shouldn’t. A “project” is everything you have on your SD card: all 
your setlists, songs, drum sets, etc. If you need to create a new set of 
songs, you will create a new setlist (folder), never a new project.

This means that after you complete the process involving File > Open 
Project (as outlined in part 1), you will never again need to touch any 
of the four options under the menu option ‘File’.

Setlist creation is covered in the next section. 

What are drum sets? What are songs? What do you 
mean “patterns/beats”?

Songs = One “unit” structured to consist of any (combination of) “MIDI 
loops”. Each of the following is its own MIDI loop: intro fill, main drum 
loops, drum fills, transition fills, and outro fill. A main drum loop is 
the beat that plays on repeat during a song part, such as during the 
verse or chorus. Every song must have at least one song part and 
every song part must have a main loop. Everything else in the song 
structure is optional. All patterns (intro, main loop, fills, etc) in every 
song are composed of MIDI files. However, the accent hit (cymbal 
crash, or other sound triggered by the footswitch) is a WAV file. When 
people say patterns or beats when referring to the BeatBuddy, they 
may mean a specific pattern within the song, or possibly the song 
itself.

We prefer the term ‘song’, since it is composed of patterns/beats.
So how do songs play? The MIDI files are the patterns and the 
drumsets are the sounds triggered by those patterns, as explained 
below.

PART 2
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What are MIDI files?

MIDI files = Similar to sheet music. They are the instructions for 
the patterns/beats being played. But sheet music by itself does not 
produce any sound, you need an orchestra/instruments.

What are drum sets?

Drum sets = This is the orchestra. Each instrument is assigned a 
number (e.g. kick drum typically assigned #36). The MIDI files (the 
sheet music), call upon individual numbers to play their instruments. 
Drum sets by themselves are just sitting there, they won’t play a 
sound unless a MIDI file is activated by the BeatBuddy and calls upon 
the instruments to play.

Do any of the songs include bass?

None of the songs in the default content or content in our library 
contain bass sounds in them. There are several songs with bass 
available on our user forum.

When a song includes bass, it includes two components:

1) Additional MIDI notes assigned to bass sounds in the MIDI file.

2) A drum set that contains the bass sounds that are being used to 
play those notes.

What are One Press (OP) Songs and One Press Bass 
(OPB) Songs?

An OP song is a song that is able to play all the way through on the 
BeatBuddy, like a backing track. This is able to be done because the 
entire song is in one MIDI file instead of in separate loops in the song, 

https://forum.singularsound.com/
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it is in either the outro or the intro - which means that in order to play 
the song (and depending on whether it’s in the intro or outro), you’d 
need to tap the pedal, and then double tap it to get to the outro, 
which will play the song.

These are different than the songs in our default content and library, 
as they are structured differently. With OP songs, you will not be able 
to dynamically change the pattern live with the BeatBuddy pedal, 
as you would with our default content, library content, and non-OP 
songs.
 B.g. using fills, transitions, etc

As the OP capability evolved, users added bass to the OP songs and 
now includes other instruments (keys, strings and horns). These OP 
songs are available as OPB, OPBk, etc. They require the latest versions 
of the firmware and the BBManager as well as user-created drum sets 
(available on the forum from Resources/Drumkits) to play and sound 
their best.

The acronyms you will primarily see on our forum for these “one 
press” type songs are these four types:

1) OP = Plays all the way through using only standard instruments

2) OPB = Plays all the way through using standard instruments, in 
addition to including bass notes (guitar).

3) OPBk = one-press bass and keys; derivatives may include s for 
strings, h for horns, etc (if the song uses or was transcribed with 4 
instruments, v4 is appended to a BB song name)

4) OPk = one-press and keys; may include strings or horns; intent 
is to give bass players their own version (v3m or v4m appended to 
a BB song name; the “m” indicates it’s minus bass)

For OP songs that include other instruments, 
you must use the drum set that the song is 
mapped to. This means that if you have a OPB 
song which includes bass notes, it will need 
to use a drum set with bass notes included. If 
you use a drumset that does not include those 
notes, you will not hear them.

IMPORTANT:
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These are, at the present time, user generated songs and are 
available on our user forum.

One way you can take a quick look to see if the drum set is the correct 
one or not is to right click on any of the song’s loops, and select 
‘edit’. It will open our MIDI editor. If there are any red notes on the 
left pane of the editor, your drum set doesn’t have all the required 
instruments.

See the example below.

The red text are all the 
instruments not included in 

the drumset being used in the 
selected song.

USERFORUM
Find and upload your files, samples, and videos 
as part of the Singular Sound Community. Get 
feedback and technical support from our staff and 
other users at forum.singularsound.com

https://forum.singularsound.com/
https://forum.singularsound.com/
https://forum.singularsound.com/
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NOTE: some additional info on OP songs
To fully understand what an OP song is, it’s useful to compare it to 
a default song. A default song is any one of the multi-part songs 
that comes standard with the BeatBuddy system (this includes the 
premium content). An OP song is user-created and was designed to 
simplify the user interface so that a user only has to single-tap to start 
a song and let it play completely through without any user interaction 
other than to stop the song.

The tradeoff is that the default beats and kits optimize the audio 
quality and provide the user with performance flexibility while the 
OP songs and associated kits’ sound quality is not as optimized due 
to system memory limitations but provides a simplified performance 
interface. To play an OPB song, the song and drum set are 
downloaded, imported and activated the same as the default content.  
If an OPB song does not start with a single-tap, try a double-tap.

Can I create my own patterns/beats? Can I make my 
own drum sets?

Yes and yes.

Patterns are created in the MIDI format, so you can use any MIDI 
creation software and import the MIDI files into the BBManager. It’s 
possible that you can find what you need in our Premium Library, 
Forum, or Song Matching Tool. Creating and using MIDI files will be 
covered in the next section.

Drum Sets can also be created, but we do not recommend creating 
them for the beginner user. They are a bit more complicated to make, 
and we have a Drumset Maker Guide to editing/creating drum sets, 
so the creation/editing of drum sets will not be covered in this guide. 
There are several drum sets on the forum and in our library you can 
obtain and use. No need to reinvent the wheel…. Unless you want to 
:-)
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What if I lose my SD card? How do I make backups?

If you already created a project as described in the first section of 
this manual, there is a backup already saved to your computer. If 
you want to copy the project to another SD card, follow this 3-step 
process:

1) Menu option: File > Export > Project To SD Card - when the 
finder window (or Windows Explorer window) pops up select 
the SD card’s drive, it will likely be called NO NAME (Mac) or 
REMOVABLE DRIVE F:/G:/H: (Windows) and then click on ‘open’.

2) It will ask you if you want to overwrite the existing project, select 
‘yes’.

3) At the end of the process, it will ask you ‘if you want to link your 
project for future synchronization’.

For WINDOWS/MAC 10.9-10.11: select yes.
For MAC 10.12+: Select yes or no, it does not matter, since you will 
need to export instead of synchronizing each time for Mac 10.12 (until 
our new software gets released, in the upcoming months).

If however you’ve not created a project and lost your SD card, you can 
get the default content from the card in our downloads page.

Instructions for getting the default content onto the SD card:

1) Delete all contents on an SD card. You can use any SD Card 4-32 
GB in size.

2) Download the ‘SD Card Backup’ file from our downloads page.

3) Unzip all the content, and put the extracted files onto the empty 
SD card. In the SD card you should now see 4 folders and 1 file - 
DRUMSETS, EFFECTS, PARAMS, SONGS and the file named HASH.
BCF (If you do not have an unzipping program, you may download a 
free one here: http://www.7-zip.org/)

4) Your SD card is ready for use!

HASH.BCF
HASH.BCF
http://www.7-zip.org/
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Here we cover: Creating setlists, copying songs, importing songs, song 
packages (folders), and drum sets.

IMPORTANT NOTES (please read):
Menu options are written in the following format: 
Menu X > Option X > Option X 
(Menu X = the main title of the menu on the menu bar)

There are two ways to import songs in the BBManager. Individual 
songs, which are SNG files. And a song “folder”, which essentially is an 
individual file you import that contains a group of songs. The “folder” 
is a PBF file. The PBF file will import as its own setlist, it’s own “folder” 
in the BBManager Project.

Song packages purchased from our online library always come in the 
form of PBF files and include installation instructions.

CREATING SETLISTS: 

You will most likely want to create a new folder in which you will 
import your new songs, or make copies of songs from your other 
folders to create a setlist.

To create a folder:
Songs > New Folder - This will create a new, empty folder in the 
list of folders (left side) in the BBManager. You can rename the 
folder by left clicking on the title, putting in a new name, and 
pressing enter.

HOW TO DO EVERYTHING (ALL THE BASICS)

PART 3

NEVER PUT IN PERIODS OR 
COMMAS in your song or 
folder names. If you do this, 
your songs will disappear 
permanently. It is a bug we 
need to fix. We mention this 
in the next section as well, but 
we included it in the important 
notes because it is a major 
bug that we have not fixed yet.

IMPORTANT:
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PLACING SONGS FROM OTHER FOLDERS IN A SETLIST / MAKING 
COPIES OF A SONG: 

You can move the song from one folder to another by left clicking, 
and then dragging it into the other folder. However, if you do this, 
the original location it was in will not contain it anymore. A much 
better option would be to make a copy and import that existing copy 
whenever you need it. To do this:

Step 1: Export the song.

Select the song you want to make a copy of by clicking on it.  
Then File > Export > Song and save it to a location on your computer 
that you will remember. We recommend using the same location 
every time you export a song, so they are all in one place. Making a 
copy of a song needs to be done only once.

Step 2: Import the song.  

IMPORTING SONGS (SNG files):
This menu option will be useful for any individual songs (SNG) you 
want to import. Most of the time, the SNG files originate from our 
user forum. They could also be songs you previously made copies of 
(exported) to your computer.

File > Import > Song - A window will pop up asking you to navigate 
to the SNG file’s location, navigate to it, and select ‘open’. The SNG 
file will import into the folder you are currently in, which will be 
highlighted on the left side of the BBManager. So for example, if the 
“Rock” folder is currently highlighted, the imported song will go into 
that folder.

NEVER PUT IN PERIODS OR 
COMMAS in your song or 
folder names. If you do this, 
your songs will disappear 
permanently.Yes, you just read 
this in the previous section. 
We are repeating it because 
it’s very painful when this goes 
wrong. We’re sorry about that 
- we’re working to fix it.

IMPORTANT:

https://forum.singularsound.com/
https://forum.singularsound.com/
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IMPORTING PBF FILES

Song packages from the library come in this format. You can also 
make your own as explained below in the pro tip section.

Step 1: First unzip the zipped file that contains the PBF file. Then 
place the PBF file somewhere on your computer where you will 
remember. (e.g., the desktop)

Step 2: From within the BBManager, select the menu option File > 
Import > Folder - A window will pop up asking you to navigate to the 
PBF file’s location, navigate to it, click on the PBF file to select it, and 
select ‘open’. This will import a folder/setlist on the left side of your 
BBManager.

PRO TIP: If you want to create your own PBF file, select the folder 
from the left pane of the BBManager and then select the menu 
option File > Export > Folder

IMPORTING DRUM SETS

Drum Sets are sold in our library, as well as created by other users 
and shared on the community forum. Drumsets are DRM files.

There are 3 steps to importing a drum set:

Step 1: First unzip the zipped folder that contains the DRM file. Then 
place the DRM file somewhere on your computer where you will 
remember. (e.g., the desktop)

USERFORUM
Find and upload your files, samples, and videos 
as part of the Singular Sound Community. Get 
feedback and technical support from our staff and 
other users at forum.singularsound.com

https://forum.singularsound.com/
https://forum.singularsound.com/
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Step 3: Go into the Drum Sets tab, and find the drumset you just 
imported and click on the empty tick box next to it. The drumset is 
now available for use!

NOTE: An asterisk (*) that appears next to a drumset in the default 
drum set menu of a song means that you do not currently have that 
drum set available in your project. Even if you have imported the 
drumset previously, this can happen if you skipped step 3 above, or 
if you have a different version available of the same drum set (e.g. 
Standard vs. Standard 1.1).

See below the asterisk (*) to the left of the default drumset’s name:

Step 2: From within the BBManager, select the menu option File > 
Import > Drumset - A window will pop up asking you to navigate to 
the DRM file’s location, navigate to it, and select ‘open.’

The DRM file will then appear in the 
‘Drum Sets’ tab, which is the tab to right 
of ‘Songs’, as shown here.
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EDITING SONGS (editing MIDI files / rearranging loops)

There are two main components of editing songs: 
1) Editing the MIDI files, which the beats/patterns are composed 
of, -and- 

2) Rearranging the beats/patterns (e.g. copying a main drum loop 
or a fill from one place to another).

1) Editing MIDI Files

• Purpose of the BBManager MIDI Editor. Our MIDI editor is a 
work in progress and thus is only suited for simple tasks, such as 
editing a few select notes. For this reason, if you want to edit the 
MIDI file(s) with a more complex task in mind (such as deleting 
several notes at once or completely rearranging the pattern) we 
do suggest you use a 3rd party MIDI editor (Ableton, Reaper, Logic, 
Protools, Cubase, etc.), and then importing that MIDI file back into 
the BBManager once ready.

• How to open a MIDI file. Right click on the beat/pattern and 
select ‘edit’. It will open up the MIDI editor. When asked to 
quantize, click yes.  It will show you the loop you opened in our 
MIDI editor.

• Export to a MIDI File (save a copy of an existing beat/pattern on 
your computer) - Right click on the beat/pattern and select “Export 
MIDI File…” - a window will pop up asking you where to save it. We 
recommend saving it to the same location every time.

HOW TO DO EVERYTHING (ADVANCED)

PART 4
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• Import a MIDI file (bring into the BBManager a MIDI file you 
have saved on your computer) - Left click on the location in the 
song where you want the MIDI file to be, and a window will pop up 
asking you to select the MIDI file from the saved location on your
computer. You can select either an empty location, or if you left 
click on a location where there already is a MIDI file, the new one 
will replace it.

IMPORTANT NOTES (please read): 
If you edit a MIDI file, it will edit the original file and thus everywhere 
in your project where that file is, the edits will be applied. If you want 
to make edits to a MIDI file in only one specific song, or apply the 
edits in just one specific place, you will need to save the file under a 
different name.

2) Rearranging beats 

You can copy one beat onto another by hovering your mouse over 
the desired beat (the frame should be high-lighted, indicating it is 
ready to be copied), and pressing CTRL/CMD+C (copy) and then 
hovering over to the loop you want to place the copied loop onto, 
and press CTRL/CMD+V (paste).

CREATING AND EDITING DRUM SETS

Refer to the drum set creation manual. It is available for download on 
our downloads page.

USERFORUM
Is there something we didn’t cover here? Get feedback 
and technical support from our staff and other users at 
forum.singularsound.com

https://singularsound.com/contact/
https://forum.singularsound.com/
https://forum.singularsound.com/

