Adding longer samples to Beat Buddy

Hello all,
I am trying to add some longer audio samples to my Beat Buddy, specifically around 2 bars of an ethnic percussion loop.

I have created the stereo audio files in 44.1 kHz, 16 bit and they are around 1.5 to 2Mb in size. I set up a new drum set in BB Manager, and load just that one sample into the first slot, MIDI Note 36, usually occupied by the bass drum.
The loop will play in the Drumset editor page in BB Manager OK, and I can save it as a new Drumset.

I then select the kit and add a MIDI note 36 in the MIDI file, but the loop does not trigger at all. If I load a different drum set the kick drum triggers fine, if I reload the new kit with the sample still nothing.
If I re-open the drum set page in BBManager, the loop will no longer play !

Any help to get this to work would be very gratefully received.

Is there a limit on the size of a single sample that the Beat Buddy will handle ? I successfully did this with a previous version of the Beat Buddy firmware many years ago, but can’t get it to work at all this time !

Is your MIDI trigger the same time length as the sample? If not need to make it so.

I think drum sets are limited to 100Mb.

Also, need to quit and then open the BeatBuddy Manager (BBM) to get it to play.

Hello, thanks for your reply.
I don’t understand the requirement to have a midi note the same length as the sample? This isn’t the case for the supplied BB. Samples? For example the crash cymbal samples behave as “one shot” samples and will run their full length no matter how long the midi trigger note is. Is it a different requirement for user samples?

When using the longer samples, I found that the BB failed to play the full length of the track, even when the sample was put in the kit as “percussion.” The cure was to put the sample in as non-percussion, and make the trigger the same length. I do not know “why” it has to be that way. I just know it works if you do it that way. It is just one of those mysteries of the universe that I accept, like gravity.

Also, your loops are likely failing to play as they have a different encoding of wav than BB wants. I found this to be the case when making wav files in Logic Pro. The fix was to use another program, NCH Switch, to re-encode the wav as wav. This apparently removed whatever nasty bits kept BBM from keeping the wav valid.

Hello Phil, thanks very much for your reply.
The loops I’m putting in are 44.1 kHz, 16 bit wave files, exactly the same as those in the kits supplied with the BB, they do play back fine when first loaded into the drum set editor, but not when triggered by a MIDI note.
Can you tell me more about entering sounds as other than percussion? What are the other options, and how would I change this?

The choices are percussion or non-percussion. Normally, when you select percussion, the entire sample plays when triggered. With non-percussion, the sample only plays for the length of the midi note. What i found was that long wavs did not play for their full length if i entered them as percussion. Again, i do not know why this is. That is just how it works.

As for the wav files, yes, i understand you have 16bit 44.1khz samples. So did I. Initially, the played. But when i came back to the kit, they would not play, and if i looked at the kit in drumset maker, the sampes were now shown in red, indicating they were invalid. NCH Switch fixed that. As i recall, there is some preference setting in Logic that could have made the samples incompatible. I’ll try to see if Incan find a thread that discusses that.

This was a reply from Goran, who makes the kits for the BB:

If you are using Logic to export your files, they won’t be playable by BBM manager, because the exported WAV files are RF64 compatible. They need to be regular WAV and NOT RF64 compatible.
If you are not using Logic to export, make sure you have not checked the option to make them RF64 compatible.

Use an online tool to convert your existing WAV files into regular Wav files.
Also, make suree they are not 32bit floating point. They should be 16bit, so you can fit as many samples as possible.

End of quote.

Apparently when I use NCH Switch, it gets rid os the RF64 issue.

1 Like

I always use Audacity to re-save my wav files.

Thanks for the additional information. AFAIK RG64 is a work in progress anyway, intended for 64 bit and/or multichannel use, so I wouldn’t expect it to work in BB. I’m exporting files from WaveLab as 44.1kHz 16 bit wave files, which is the same format as the BB supplied kits use.
The files will load into a drumset ok, and can be auditioned, (until the kit is saved) but are not triggered by a MIDI note?

After you load the wavs in the drum kit, and then quit BBM, upon opening the kit, can you still trigger the note within the kit? Do the wav appear to still be in the kit, or are they showing in a red font? If the wavs can still trigger in the kit, there is likely an error in your midi file. Check wavs, as mentioned in the 2 questions, herein. If you have an audible wav in the kit, export the midi that you are trying use as trigger. To do that, right click on the song section within BBM, and there will be an option to export the midi file. Then open the midi file using the program that you used to create it. Are the midi notes where you expected them to be? If they appear to be missing, do they appear much later in the song? If the original midi notes were very short, i.e. less than a 1/16 note, select all, and make the notes longer. Then retry. If the notes in the midi file appear correct, I would need to see your custom kit and you midi files to tell you what is wrong. You can send them to me at

Since you indicate, or at least imply that the wavs cannot be auditioned after you save the kit. The likely problem is in the wavs. Download NCH Switch and give it a try. Its free for non-commercial use, or at least it was last time i had to update it.

1 Like

Hello Phil, this has been very helpful, thank you very much. Despite exporting the wave files from an “Industry Standard” editor like Steinberg’s WaveLab, it seems BB didn’t like something in the format! Running the wave files through Switch seems to have made them acceptable, and I’m making some progress. The next step is BBs interpretation of 98bpm isn’t quite the same as that of Cubase and ProTools, but that’s an easier fix! Thanks again for your huge help.