Aeros 3.1 bug

This is complex but stay with me here. Playing in 2x2 (settings: CHANGE SONG PART/STOP SONG [End Of Loop]. PLAY/STOP ALL BUTTON [Release]. TRACK BUTTON ACTION [RPO]. Layed down initial recording plus one overdub (on first track of each song part), then on second track of first song part recorded a melody. Upon second play through of first song part loop I undo second track (first song part) then proceed to second song part. After one time I switch back to first song part and attempt to redo the undone (second track) and it played back totally out of sync. I couldn’t re-create this anomaly but then I got it to mess up again. Upon redoing the previous undo (which in this case needs to happen immediately as the first song part begins playing) the second track plays out of sync. If I completely stop the Aeros and restart it is back in sync.
(I hope I put this in the right location - I’m forum challenged)

Hey there, I will try this out, in the mean time, can a mute work in this case instead of undoing? Also, are you in quantized mode? How long is each track/ which is longer?

Also, please let me know, is sync length on? is sync start on as well? (check in the song settings) Did you record it with an offset (the tracks start at different times)?

I’m in Free Form mode both tracks in song part one are the same length. (How do I set what the actual length is?) I see I’ve used 23% memory. Is there a quick command to mute a track?

For sync length, do you mean when you touch the “pencil” and there is a category SYNC TRACKS? Underneath is greyed out but a dim blue box is on “Start & length”. I did not intend to have an offset. I started the second track at the beginning measure of the first track. Oddly, in recreating this scenario to answer these questions, in song part two, at the end I add a second track which I want to record over three times to achieve a three part harmony and instead it just keeps on recording (longer than the first track length).

I think I just saw this is quantized mode, 2x2, driven by the BB. Like the OP, I did an undo and (re)record.

Sometimes the loop is in sync with with the BB and other times not. I would blame my timing, but this is after switching to a new part where it has lined up perfectly in the past.

The issue just went away now without me doing anything on the song … perhaps since I’m starting from “stopped”?

The only other odd thing is that there were a number of times when it felt like undo was not taking effect.
It might have been errant foorpress, but it took about 4 takes before the record worked … and pretty sure after the 1st “miss” I did fully press the button. Will log this in another bug, but they happened in the same session.

There is no way to set (or maybe you meant “see”?) what the length is

Quickly double tap the track action button (the one with RPO commands) for the track you want to mute

This is what I meant, yes, thank you.

Are you telling the looper to start playback?

As a general rule of thumb the Aeros does not automatically stop recording or do any action automatically, you must always tell it to do something first. The sync track length and start only aligns the tracks to be the same length (or whole number multiples in freeform) once you tell it to playback and makes it so that the start point is always the same.

Here’s the definition of the sync modes:

Sync Track Features

  • Definition: “Base Track”: The current longest loop in the song part when in quantized mode. In Freeform mode (non-quantized), the base track is the shortest loop in a song part.
  • Sync Length: After 1st track is recorded, all tracks will be forced to be proportional to the length of the base track. In quantized mode, all tracks will be forced to be any whole number multiple (x2, x3, x4, etc.) or whole number unit fraction (½, ⅓, ¼, ⅕, etc) of the base track. For example, if the base track is 12 measures long, other tracks will be forced to be either 1, 2, 3, 4, 6, 12, 24, 36, etc. measures long depending on when the end recording/start playback command is given. In freeform, all tracks will be whole number multiples of the base track (no fractions allowed). Tracks can be started at next measure in quantized mode, or immediately in freeform, so this only affects when recording stops and playback begins.
  • Sync Start & Length: In addition to the Sync Length rules above, after 1st track is recorded in a song part, all new recordings will begin at the next start of the longest track loop in the song part.

We have had automatic recording and playback modes requested but that is not currently a priority.

To do what you’re saying, first record track 1, then record track 2, and hit playback before the end of the loop, it will set up to playback that recording. If you give yourself enough time, you can also change the playback into an overdub event by tapping once more, so once you reach the end of the loop on track 2, it will begin recording the overdubs for your layered vocal.

Ok, I will save any questions I have for that entry, then, thank you for reporting this

This is related to something another user has claimed on 3.1.3, we are looking into what could be causing this perceived shift, and it will be included on the final release of 3.1.x if we find something.

I am just not able to recreate this, could you possibly make a video showing what you’re doing? The best way to do this is upload it to google photos and then create a shareable link.

Could you tell me, when do you redo the track? Before the 1st part begins? You’re using the hold to redo, or are you using a MIDI command? Thanks

It would be difficult to video. I think I discovered how to effectively implement the mute feature (and for this song it works great as it gives me the option to unmute prior to re-entering the song part with the muted track). It’s way easier and eliminates the chance of totally erasing a track because of uncoordinated foot presses. A side note: random times when doing an overdub, the visual waveform shows up late on the time line but is audibly in time.

Ok, Have you seen the timing bug happen again? If I can’t re-create it we can’t fix it, I can make a video showing you what I’m doing, and you can tell me if I’m following the steps correctly.

Ok. I won’t be able to attempt a video for a few days as I’ve got a lot going on right now. Thanks for all your info.

The out of sync track corrected itself for me when I stopped and restarted the Aeros.

I may have recreated the bug! Question, did the audio shift back into place on the next loop around? How much delay did you notice? Just a little or was it playing back from a completely different place?

This may be related to another bug we are currently looking into.

Thanks

I didn’t let it play through so I can’t say that it corrected but I did notice after stopping playback and restarting it was correct.

Thanks for all the info, very helpful

1 Like