Aeros 5.0 update problem

After a few months on the shelf, I decided to try the new firmware 5.0 after hearing it was no longer beta. I have tried multiple times to download the update using WiFi, but I am unable to download it. It says that it is already up to date even though it is on 4.3.1 (it’s still working but I still want to update it). So then, after I saw that you could update it using an SD card, I downloaded the update onto my Mac, but whenever I try to move it to the SD card, it says that it is an “unsupported format”. I then tried on a Windows laptop, but it wouldn’t open on there at all.
Please let me know what I can do to fix this issue. It was very expensive, and I am unable to use it properly.
Many Thanks,

All done, managed to fix it. What I managed to do was when I downloaded the update from Singular Sound website, and when it asks where to save it, I saved it straight into the SD card on ‘Locations’, instead of onto my Desktop like what I did before. I don’t know if that was simple for most, but it might help someone else with the same problem.