Aeros and beatbuddy losing midi sync mid song

Hi, I’m having a serious issue with my midi sync between the aeros and beatbuddy. When I stop the song on the aeros and start again it’s not waiting till the end of the measure and starting straight away. I’ve tried new midi cables new midi break out cable, I’ve removed my pedal power in case of interference etc. I believe others are having the same problem. I can make the fault happen by disconnecting the midi cable and reconnecting mid song . Has anyone got any suggestions of a fix please.

1 Like

I run into this with loopers while using external clock all the time (the Aeros and other loopers). The local “play” control used AFTER a clock has already been started is immediate, while the record/new track control tends to have the ability to be “quantized”.

The solution I use when this is a problem is to mute the looper instead of stopping it, letting it stay in sync until I want it to be heard again. it’s funny that Mute controls can also be quantized (cued) while Play often cannot. It helps that I use a small programmable MIDI Controller to make this happen as I can mute multiple tracks with one click. Even then, it’s not a perfect solution. Problems arise if you want to switch parts while muted in order to cue up a part change, because mute only applies to the part you were on when mute was sent.

The easiest thing, of course, is to be accurate when you hit play. (Not always possible if my foot is dedicated to something else at that moment).


Hi thanks for the reply. The start/stop is normally quantized, so it will start at the start of the next measure. However intermittently and very random it will not. Also what small midi controller do you use? And where do you plug it in? I’m guessing into the beatbuddy and have the midi setting set to thru?

Apologies if I’m barking up the wrong tree. I interpreted the issue you are discussing one way that I know … if you are actually experiencing something else you know is happening randomly, then that would be something else.

What I’m referring to is:

It’s only when you Stop on the Aeros while the external clock (Beat Buddy) is still running, then hitting Play on the Aeros, that it will not cue to the start of a Bar. Other times, using the 3 lower buttons while the Aeros is already in Play mode, every action can quantize. The difference, IME, is always between Stop on the Aeros or not, it’s never random, at least not for me.

I use the Morningstar MC-6 for MIDI Control. I place it in front of all the devices I want to send MIDI to, and yes, each device must support MIDI Thru to carry the MIDI signal on after it if you don’t want to get into using a MIDI Splitter.


What’s crazy is I programmed my own MIDI Clock/Transport/Metronome into a pedal that supports setting a Time Signature and has the ability to cue custom MIDI Messages and send them to a looper at the top of the bar. That’s how much I’ve thought about this.

My device will work even better once Aeros’s MIDI Implementation is more complete, but it’s great with other loopers since, as I said, this isn’t a behavior that is Aeros specific. Only one looper I have, the Pigtronix Infinity, keeps track of where the top of the bars are when it is stopped while still receiving clock, and will cue Play to the top of the next bar on it’s own.

1 Like

Thank you for the feedback and information!

We are currently investigating the bug, we believe it has something to do with Aeros intermittently losing count with the BB’s 1 but will also investigate other claims made here.

Thanks for reporting!

Once my Aeros updated to 4.0.0, I noticed when I record a few loops and then stop everything, the Beatbuddy and Aeros BPM are not in sync. The Aeros BPM reads one beat per minute higher than the Beatbuddy.

This most notably leads to a short gap at the transition from Loop End —> Loop Start, which renders the unit unusable.

I’m reverting back to the previous version of the firmware until this is fixed.

Hey there, just to be sure, you are positive the BB didn’t go down in tempo after recording? Does the Aeros show the correct tempo on empty songs? Can you reproduce this?

This bug is not being reported by any other user meaning it may not be reproducible, meaning it is highly unlikely it is caused by 4.0.0. You can revert if you’d prefer but you are not likely fixing the issue that caused this.

If you can reproduce it please let me know!

The Aeros losing sync with the BB beat count intermittently is not related to your issue, if you’d like you can open a new issue but currently this is off topic

Thank you for reporting, feel free to DM me or open a new issue with related info to your issue !

Encountered this a few times yesterday.

Initially I thought it was related to using immediate stop (double press of all stop) but I can’t (so far) deterministically reproduce it.

Once sync is lost the aeros performs immediate start (as noted above) when you hit play.

The only way to recover sync is to stop the beatbuddy and then start it again.

I’m hoping this is the same issue:


I did some digging on this myself and figured out why sometimes Aeros syncs back up or not. It’s about whether or not the MIDI Clock is allowed to run for a couple beats before sending MIDI Start when the song original began. A MIDI “Cold Start” is where the problem lay. I made a private video to demo this. You can at least use this info as a work around until the firmware gets released.


This beta should solve this issue!

Thanks for this form note, I just sent an email to you about this last night before I saw this forum conversation. Has there been any fixes?

Thanks for the video. Have you tried to use this work around in a live setting?

This has been fixed for a long time, it was fixed in 4.1.x

Unfortunately, it did reappear in a slightly different way in 5.0.3, but it is already fixed internally and we hope to have that version out very soon

It is an avoidable bug however read more in the Known issues of 5.0.3 at the bottom of the first post in the thread.