Aeros Firmware 5.0.x

  1. First: congratulations ! I’ve been having a lot of fun with Autoquantize + BeatBuddy
  2. One suggestion about FADES : I would like the BB to fade along with the Aeros. One solution would be to plug the BB OUT in the AUX IN and to be able to define that the fade applies to the LOOP + AUX. Would it be possible ?

Thanks a lot for this beautiful 5.0.0

Not to be a grinch or anything, but those of us who are owners of the original Beat Buddy and have been waiting for years to get an updated BBM have nothing but coal in our stockings. You seem to support your newer products while ignoring the product that started it all.

Buddy, why do you use BBM? I give up this garbage long ago.
I am using Logic Pro.

Looks like it’s multiple time signatures in a song

I use lots of other software. I’m partial to Sonar for MIDI editing, Mixbus 32 for tracking and mixing, Audition for 2-track editing and mastering, and the list goes on. But I still wish that Singular would give us a decent computer interface for Beat Buddy. It would make a lot of things more convenient, reduce importing and exporting MIDI files, and could, in conjunction with the excellent loops and sounds of Beat Buddy, give us whole new ways to compose and perform. Oh well, maybe some day. Meanwhile I’ve got plenty to keep me busy.

Looks like Xmas :christmas_tree: ! A long time since I’ve been login in for the last time…

But it looks like the two main features I have been requesting back in April 2020 are finally now implemented! I was not expecting anymore.

My Aeros was still in 4.0… for quite a while, and clearly 5.0 seems to be a giant leap, with not only the two aforementioned features implemented, but a ton of other goodies.

I quickly tested those two, and for the first one at least, it looks like fully implemented (I will tag my initial request as implemented).
For the second, although it seems to work, I didn’t find a way to make the BeatBuddy align with the tempo deduced from the initial recording in auto-quantize mode…

It may be a connectivity issue (I am no Midi wizard), a setting that I may have missed on either the Aeros or the BB or even maybe due to the fact my BB has not been updated for quite a while too…

If someone can point me to a comprehensive explanation or a step-by-step guide on how to achieve this, it would be pretty awesome. Thank you in advance.

Thanks again @BrennanSingularSound, @DavidPackouz and of course the whole team for releasing this !

PS: I join my voice to the others regarding the fact the whole BBM story is really painful… but that’s another problem.

1 Like

Hi,

Great upgrade, haven’t had time to test everything yet.
I hope the next one will concern the mixer with a pan, possibly a low cut, and routing management.

Thanks

1 Like

It’s a great update, but it seems that some of the MIDI messages either changed or no longer work, so there will have to be some reconfiguration of those at some point. For example, my “Song Select” MIDI message no longer works, although it is easy to do now on the Aeros itself.

I am really happy with 5.0 for what I use the Aeros for.

Is there an updated Google Doc of midi commands for 5.0?

1 Like

Just got around to installing the 5.0 update. The installation worked flawlessly using a Mac and Safari under macOS Monterey.

I converted my old songs using the process described in the initial post (including backups first!). Worked flawlessly also.

This update is impressive and delivers great new features. I have not tested all of them yet.

I tried to use backing tracks without success. I connected the Aeros to the Mac with a USB cable. The internal memory of my aeros is not seen by the Mac’s finder. Only the SD card is seen. This might be normal? But the SD card is only readable and I cannot change this using the standard Mac Get Info window option to change access privileges to the SD card while it is in the Aeros. I was able to transfer a backing track by inserting the SD card directly in the Mac…

I used a WAV file and an MP3 as I did not find any instructions on what type of file format was compatible as a backing track except “The Aeros will only support files that are 44.1kHz and 24bit. They can be mono or stereo.”

The instructions say:
To load a backing track:

  • Edit the song
  • Select Load File
  • Choose a file from the list using the Right Aeros button
  • Once selected, click save

I tried this on a new song in 2x2 and another in 6x6. I could not find the Select Load File option…

Any help on this would be appreciated as this is a feature I have been waiting for.

Best Regards

Yeah, the file type (WAV, .mid, .mp3, etc) compatibility is the info missing. I know .mp3 files don’t work, but I got one type to work fine but can’t remember if it was a WAV file (I think it was) or a .mid file. SS needs to weigh in on this for the correct file extension for backing tracks. @BrennanSingularSound

Don’t forget, I’m pretty sure your “new” empty song has to be in Freeform mode and not quantize mode.

*.mid files are not audio files.

*.mp3 files quality are measured in kb/s, and sample rate 44.1kHz

The attributes mentioned only apply only to PCM files, ie, *wav files. So only wav files, I would presume wav.

1 Like

Thanks Steve your re quite right! That should have come to me as well! :grinning:

BFRedrocks, thanks. That may be the problem! I think I was using a quantize mode new song. Will try a freeform and revert.

ps and addendum: Yes that was it. The Load File option shows up just below the mode selection menu item when you select Freeform Mode. It is working perfectly now.

This is a great new feature!

2 Likes

Awesome! Happy to help. :slight_smile:

It seems the file type accepts 16 bit or 24 bit Wav files… Both worked for me…

Great update, had another quick play with it.

Setting the temp precisely with slider is a bit frustrating could with a +/- button to fine tune.

Not sure if I’m missing something but in 2 x 2 mode the new pop out side bar is difficult to use. If when you open the side bar and it is set to bottom track and mute but you actually want top track reverse you will end up muting the top track or reversing the bottom track. As soon as you select either track or option the change is applied

Edit: This is using the touch screen, can use the scroll wheel to select option then select the track , didn’t think of that :zipper_mouth_face:

2 Likes

Agree with you for the slide the +/- excellent idea

1 Like

Update worked fine for me. Got a backing track installed. Discovered that after getting one track working, I could add a second track by repeating the process in the same song. (Much thanks for that long video a user supplied on how to) So I have a separate Piano and Bass track going in a backing track song. Doesn’t seem to be a way to change volume on individual tracks. Have not tried it yet in 6 track song.

1 Like