Aeros Firmware 5.0.x

Here’s a copy of the file, zipped: aeros-5.0.0beta1
The link expires 12 hours from the datestamp of this post.

1 Like

Words do not suffice to express my elation at discovering the new menu system!

It will cut by 90% the amount of aspirin I need to purchase!

So happy Chrismahanukwanzakah to you too!

1 Like

I installed the new firmware (twice actually) and had some problems… It had trouble loading songs. It would either give an error message or just load forever. And it didn’t want to open any of my converted old songs, it would just open a blank song.
I have a pretty early version of the Aeros if that makes a difference…

Since the new 5.0.0 version provides the option for the Aeros to be the midi master, can someone advise as to what midi settings need to change (if any) in the BeatBuddy for the BeatbBuddy to be the midi slave? I think I need to disable the sync out so the midi clock is not transmitted, but is there anything else that needs to be disabled or enabled?

Totaly agree with this statement I also requested this to be looked at 2 years a go to get around it I recorded the BB ont one of the tracks to eatch song. I am 60 and all that bending over and scrabaling about on the floor trying to find the beet used ect is inpractical,I have ditched the lot now and gone back to basics eg a microphone and tambourine in a box taping it eith my foot and playing songs live with no looping,no fafin about and the abilaty to chang songs in a split second.

Multi meter……I wonder that to

I updated Eros to FW 5.0.0 and it was ok. But in the first tests I did, my MIDI commands for song selection no longer work, besides crashing Eros.

Can someone who has switched to the new Beta firmware confirm whether or not the Beat Buddy will cause the Aeros to transition to the next song part in 6 x 6 mode without having to select the next song part on Aeros using the Aeros itself?

I love and appreciate everything you’ve done here and all the hard work that has gone into it. It seems like one change that many people have asked for over the years is not on your to-do list. That is the ability to limit the 6x6 to 6x4 or 4x4 any other other configuration of parts to lesson the unnecessary tap dancing one must do if they need less parts and don’t have midi. Thanks for listening!


Hi, new member. I’ve had the loop studio for a couple years but it’s been sitting on the shelf for a while.
I saw the beta announcement so I gave it a whirl and I think it’s a big improvement. fwiw the update was pretty easy to install and the UI is way better now. I used wi-fi to update to 4.3 before I did the SD method for 5.0. I’m excited to give this another try.

Like collider, my Aeros has been on the shelf. After not using it for over 2 years, I will re-engage! Fingers crossed! :slight_smile:

Update: No matter what I do it doesn’t update from the SD card. I have update 4.3.1 on my Aeros. All it says is: “All Up To Date”. Any ideas would be appreciated!

  • Delete the Aeros firmware file you previously downloaded from your computer and your SD card;
  • Download the Aeros beta file again; make sure that its size is 103.9 Mb (at least that’s what it is on my Mac); if you download the zipped file shared by steve606 (below), it too should be 103.9 Mb but if not, download it again;
  • Rename the file you just downloaded to aeros.bin
  • Make sure your SD card ≤ 32Gb class 10 SDHC and is unlocked and that it’s formatted as FAT32; no need to re-format unless it’s not FAT32; here’s how to check using Windows: How to: Check SD Card Format in Windows 11, 10, 8, 7 and here’s how to check using the MacOS: ctrl-click the SD card and select Get Info;
  • Copy aeros.bin to your SD card;
  • Power off to pedal; disconnect all patch and MIDI cords from the pedal;
  • Insert SD card in pedal;
  • Power pedal on.

Let us know if anything in particular helped or what you end up having to do to get it to work.

Tried it again, didn’t work. File being downloaded is not a zipped file! Link provided looks like this:

I think some browser setups will refuse to download a binary file.

You might try the zip archive I posted earlier:
This link expires 12 hours from the datestamp of this post.

1 Like

Please let Us know if steve606’s solution works. I’ve updated my previous post (above) with some additional steps.

1 Like

I found and am trying that link. It downloaded as a zip file. I’m doing a long format on my sd card. I will post back once I’m done! Thanks for jumping in so quickly with your help!

1 Like

Also, be sure you rename the file to aeros.bin – easy to forget that part

Not forgetting any steps. Still not working. The files I’ve downloaded are only 99.1Mb’s.

Very strange – especially that the error message is no error message and the unit just boots up.

That is also what happens if the file has the wrong name, or is not actually a firmware file.

Of course you’re not renaming the zip file without extracting? The size you give is the zipped size.


No, only after I’ve extracted.