Aeros Loop Studio Tempo: Integer or fixed-point internally?

I’m the new owner of an Aeros Loop Studio. I received it today and I’m looking forward to delving into it a little more. It arrived with firmware version 3.0.0, and while I ran into some hard crashes when I attempted to update it the first time, I was able to successfully update the firmware to 3.1.10 after connecting to my wifi hotspot.

I have a question about the tempo for the Aeros Looper (preferably for Singular Sound or the developers).

I notice that the tempo display is an integer value. I use a Line 6 Helix and I’m attempting to set up MIDI sync between these two devices and an Alesis Nitro drum machine (just for backing drums). The Helix displays its tempo to a precision of a tenth, and it looks as though the Aeros display will round to the nearest integer. (If I set the Helix to, say, 90.5 bpm, the Aeros will fluctuate between 90 and 91.)

Internally, does the Aeros track tempo using a fixed-point representation or does it only use an integer value? I’m trying to troubleshoot some MIDI sync issues and this information would help me.

Thank you!

Hello there,

Sorry to hear that, were you having issues while clicking the pop-up to update firmware via WiFi? We have made efforts to fix this bug, hopefully you will not see it when updating from here on out.

The Aeros currently only responds to whole number integers, we do not currently have a plan for introducing smaller values.

Appreciate the feedback

Sorry to hear that, were you having issues while clicking the pop-up to update firmware via WiFi?

I had a couple of issues (but again, note that this was firmware 3.0.0, which came installed on the hardware):

  1. I attempted to connect to an “xfinitywifi” network - I doubted this would work, as those networks require a web browser for authentication purposes and so many devices aren’t able to use that network. I then connected to my phone’s hotspot, which uses WPA2 authentication, and the WIFI manager seemed to crash (I got a message saying server not available, and I couldn’t enable WIFI on the device to get a list of hotspots). This happened twice; I was able to reboot the device, connect to my hotspot, and put in a WPA2 password. This could have been due to a number of network exceptions that weren’t handled correctly - no way to be sure.

  2. After connecting, I downloaded the update once, and upon rebooting I got an error screen:

    "Error code 0.

    1. Please insert a valid update file using the SD card
    2. Unplug the Aeros power supply
    3. Reconnect the Aeros power supply

    Wasn’t sure if I’d bricked it, so rebooted it to verify. It booted the 3.0.0 firmware, and running the update again worked correctly. Not sure what happened there.

The Aeros currently only responds to whole number integers, we do not currently have a plan for introducing smaller values.

Thanks for your response. While I can understand why this is the case, I think that an integer tempo representation might cause MIDI sync issues with MIDI devices that have higher tempo precision (like the Line 6 Helix, unless its tempo is set to a whole number) or older devices that report a tempo as an integer but their MIDI clock tempo reported interval is slower or faster by a a fraction. (It seems that my Alesis Nitro falls into the latter category; when I do MIDI sync with the Alesis as the master, the Alesis and the Aeros are off by 1 bpm; the Alesis is 1bpm faster.) The Aeros seems to try to round to the nearest integer based on the average tempo for some set interval of MTC information.

With the Helix, I can work around this if I use an integer tempo. Unfortunately, with the Alesis, I don’t think there’s anything that I can do here to make them sync.

So just as a heads up, if anyone else runs into syncing issues, it may be an integer precision issue. Another device used as a MIDI master may have a non-integer tempo value (even if the device reports it as such) and the Aeros may not be able to sync perfectly with that external device’s timekeeping. I know you guys have a roadmap of features that users are clamoring for (loudly), but I’d like to humbly add this one to the list; I think that higher tempo precision might be a core concern that would allow for better MIDI syncing between the Aeros and other devices.

If there’s something that I’m missing, let me know. I’m happy to take any suggestions if I’m missing something; I’ve got a couple of MIDI cables and if necessary, I can log and analyze the MIDI messages coming from the Alesis to verify my hypothesis about the skewed tempo.

Hope this helps.

Integer only tempo is gonna cause you problems when you implement auto quantise. Fixed point will be workable if you include enough sub-bpm resolution, but the idea that when we would be exactly 1 BPM when changing from R to next in RPO or ROP is wishful thinking.

What’s more, because beats per minute is not a linear unit of time, it’s a reciprocal unit of time (frequency), you’ll find the accuracy of the tempo gets less and less precise at lower BPM.

e.g. 1 BPM is a period of 60s, 2 is 30s, 4 is 15s … So plus or minus 1 BPM is a different amount of time depending on the BPM. In the extreme case, imagine rounding up to 2BPM when you entered a loop of 1.55BPM …

I really hope you’ve just misunderstood the question and aren’t storing times in integers of BPM.

Just as a heads up, I think I’ve solved my MIDI issues. I’m not sure what caused the problem. While it does look as though the Aeros rounds its tempo display, I’m not having problems with MIDI sync any more.

My hunch (unverified) is this is working, now that I’m running the drum kit MIDI out directly into the Aeros instead of running the drums into the Helix and the Helix into the Aeros. It’s possible that I may have had the Helix configured incorrectly (it’s set to send out MIDI clock) so perhaps the Aeros was receiving two sets of MIDI clock signals? I wouldn’t think that this would be the case, but since the Helix has a MIDI Out/Thru port, perhaps it’s possible. I would only be able to know if I analyzed the MIDI messages using the same hookup. (Interestingly, the drum kit does send start/stop MIDI messages, but those aren’t passed through the Helix, so maybe there was something else going on entirely.)

Sync seems to work well at slow tempos and although I’m still seeing a tempo mismatch between the kit and the Aeros, sync seems to be working as expected.

1 Like