Aeros MIDI sync from external keyboard

I am trying to connect my Yamaha Clavinova keyboard (master) with the Aeros (slave) both through MIDI and audio.
My goal is to record some audio tracks from the keyboard arranger (styles) while having the Aeros clock in MIDI sync and responding to start/stop messages.
I can then solo over (badly!) or add overdubs to this track.

Here is what I observe:

  • After connecting the MIDI cable (keyboard OUT into Aeros IN), in the Aeros song panel, the “MIDI sync” value is always showing “off”. When I connect the BB instead, it moves to “on”.
  • When I change the tempo on the keyboard (before starting the recording), the tempo value is not changing automatically in the Aeros song panel. Again, this works fine with the BB.
  • When I start playing on the keyboard, the recording starts correctly in the Aeros (the start MIDI message goes through) and the bar grid follows the keyboard tempo (even if the Aeros tempo number has not changed and is still showing the inital Aeros tempo). So it seems that the MIDI clock goes through while playing, and that the Aeros is aligning to it.
  • While playing, the audio record is good and perfectly in line with the displayed bar grid.
  • When I stop playing on the keyboard, the recording on the Aeros stops as well (good)
  • When I play the recorded track, the Aeros tempo and visual bars go back automatically to the original tempo (different from the ones shown during the live recording) and the audio chord changes are therefore out of sync with the bars displayed. So I cannot rely on the bars anymore to solo over the recorded track.

For now, my fall back option is to use the freedom mode but that is frustrating.
Is there anything I do wrong?
I can record a video showing the issue if helpful.
Note: Aeros firmware version 3.1.18.

Since the Aeros seems to prefer the BB, you might try putting it between the Clavinova and the Aeros in the midi chain. You wouldn’t need to record or use its audio. Run your midi chain as Clavinova>BB>Aeros. Be sure that BB is configured to receive and transmit clock.

Thanks @Phil_Flood
With the MIDI chain Clavinova>BB>Aeros things are a little bit different (and better) but still not perfect.
Here is what I observe:

  • When not playing, changing the tempo on the Clavinova does not change the displayed tempo on the BB, and not on the Aeros either.
  • When start playing on the Clavinova, the BB starts correctly (count in is set to none in the BB) and the tempo played is the one from the Calvinova (good).
  • Even if the Aeros songs’ countin bar is set to 0, the recording starts only 1 bar after the start. The display of the bars starts correctly though.
  • The sound wave form is not always shown in the Aeros display during the recording. The bars are shown, with the correct timing in line with Clavinova & BB.
  • Stop is in sync with all: Calvinova, BB and Aeros.
  • After the stop, the tempo is now automatically and correctly displayed on the BB (was not before the start) but still not in the Aeros.
  • Press playback the Aoeros: timing and bars is OK (good and most important!) and the waveform is showing correctly. But the first bar was not recorded.
  • The tempo displayed in the Aeros song panel is still not correct and not in line with the one of the recorded song, nor the one displayed on the BB.

I think there is a fix for that first bar issue, but I cannot recall offhand what it was. Maybe someone else can help out.

Is the first bar issue, the intro? Does disabling the Intro on the BB help?

I was getting some erratic behaviors as I forgot to disable the MIDI merge function of the BB, and so some MIDI commands were therefore going from the Clavinova to the Aeros and disturbing the flow.
So now I am getting the best results with the following setup, keeping things very straightforward:

Clavinova -> BB --(no MIDI Merge and no audio)–> Aeros

In particular, only the BB controls the Aeros, and the Clavinova controls the BB.

With this, I can at least do what I wanted initially: control the tempo + start/stop recording from the Clavinova.

Things that still do no work:

  • See the tempo figure change when not playing, on both the BB and Aeros.
  • After playing, see the correct tempo figure on the Aeros panel (recording is done with the correct tempo).

Next on the test list: see if I can trigger an Aeros song part change from a Clavinova style part change. That would be great since I could then record an entire song structure from the Clavinova in one go.

Looks like you got the basics working the way I thought they should. I’m kinda surprised that the correct playback tempo does not show on the Aeros. But is it now playing back at the correct tempo?

Yes, it’s playing back at the correct tempo and bars are correctly displayed and synchronized.
Only the displayed tempo number is wrong, whereas the one on the BB is correctly changed (but only after starting playing from the Clavinova). Strange as the BB is controlling the Aeros. Anyway, not too annoying as long as the recording tempo is OK.

The biggest problem is that the Aeros is showing “Off” while midi sync should be active. If this is the case, it very well could be the setup on your Clavinova, make sure that there is not an internal setting that allows the Aeros to read the clavinova’s clock.

The biggest hint that the issue may be within the clavinova is that the BB is also not responding as expected. Does the BB show a small blinking icon where the tempo is? This shows that the BB is correctly receiving MIDI clock.

Please let me know!

The BB and the Aeros will always adjust if they are listening to MIDI clock correctly. I will also bring up that the Aeros cannot change tempos once it is recorded to, every song must be in a static tempo, the Aeros does not currently support tempo changes either during recording or playback.

If this is the case, it very well could be the setup on your Clavinova

Well, as I said, I gave up trying to connect the Clavinova to the Aeros directly. As @Phil_Flood suggested, I rather put the BB in the middle, to let the Clavinova control the BB (and only the BB), and the BB control the Aeros. Also, I disable the MIDI merge output on the BB, to make sure that no commands from the Clavinova make their way to the Aeros directly.
This simple setup works better, as we know that the BB ↔ Aeros MIDI connection works well (obviously).

What I realized today is that if I make a new song on the Aeros, the correct tempo gets propagated and displayed on BB and the Aeros as soon as I start playing (but never before playing, like it does when turning the tempo knob on the BB). As you said, I can see the tempo blink on the BB with a sync sign (double reverse arrows).
However, if I press “Delete all” on the Aeros, without making a new song, and then change the tempo on the Clavinova (to start over the song with a new tempo or style), the new tempo is correctly displayed on the BB but not on the Aeros. This is what I was observing yesterday.
In fact, I suppose that “delete all” just deletes the tracks but keeps some settings of (previous) song. The displayed tempo won’t change then, even if a new recording is done with a different tempo. Bars are aligned correctly, song is ok, but the displayed tempo is not in line with the recording one anymore.

Starting with a fresh song each time makes things better now, and the setup is usable.

Of course, for people not owning a BB (ok they should!), they can have hard time connecting their keyboard/arranger directly to the Aeros. If not restricted correctly, the keyboard can send a lot of MIDI data not useful and even confusing for the Aeros.

It sounds like it could possibly be the way the data is streaming from your Clavinova, I do not experience this issue when working only on the BB and Aeros. It may be worth checking out the behavior of the Clavinova’s MIDI sync and when it is streaming the clock vs. when it isn’t. I’ll ask dev to see what they can say about the issue.

I have a similar issue, I would like the midi clock from my MPC Live to control start, stop, record and play on the loop studio. I have followed the instructions but the midi synch still says off. And such doesn’t seem to work. I sure hope I can solve this issue otherwise I will be returning the Aeros… seems like midi such should just work without hassles

Reply to myself here. It all started working rather nicely. I can start a song on the MPC and the Aeros starts recording and tracks the tempo nicely. I think I just needed to restart the MPC or something.


I’m having ta similar issue, trying to control Aeros from Logic X on a Mac, talking USB to a Focusrite 4i4 MIDI port. I am trying to Start, Stop and Tempo on a brand new song 6x6. It is Starting and Stopping just fine. Tempo is not.

I have Logic streaming MIDI Clock when I press play. Using MIDI Monitor, I see System Clock broadcast to my 4i4 port, which thrus it to Aeros In, Aeros is Receiver, along with System Start and Stop.

The music plays from Logic at 102BPM. I have the BB downstream from the Aeros, and I see the BB Tempo change to 102, and flash accordingly, BB Starts and Stops right along with the Aeros, controlled by Logic Play/Stop.

Use Case 1 would be brand new 6x6 song created on Aeros, Auto record, Audio In from Logic out. Set tempo in Aeros to desired 102BPM. Arm Part 1 Track 1. Hit Logic Play; Aeros begins record, BB starts playing displaying 102. Logic Stop after 8 bars. Aeros and BB stop, BB shows 102, Aeros shows what seems to be a random number for Tempo after stopping and song page displays. Hit Aeros Play to review, and it runs at the random tempo, while the recorded audio replays plays at the expected Tempo of 102. End of Loop will now be long or short, depending on whether the random Tempo now displayed is less than ( EOL too long) or greater than (EOL too short) 102, shown correctly on Logic, MIDI Monitor, and BB.

In my thrashing about, I have observed several more use cases; I’ll try to document them but I’m spending hours now repeatedly trying to get this all to work so the frustration level is very high right now.

It would seem the MIDI implementation on BB is rock solid, but Aeros is finicky as all heck.

Adding to the frustration, the Song Edit → Set Tempo slider is nearly impossible to get the converge on the number you want using finger touch on slider; the number will jump unpredictably when you lift your finger from the slider. Perhaps you can change the tempo setting using the wheel? I haven’t tried that yet.

Question for y’all. When creating a new 6x6, with external clock, should it not start with an undefined Tempo, ready and waiting to see the external clock on System Start? Perhaps an explicit External Sync control is needed for Song properties?

I know you will probably tell me to buy a MM; I will, but not until $$$ at end of month for me. I have made great strides understanding the BB/Aeros MIDI behaviour, but I can’t help but see this inability to remote Aeros from Logic as a huge problem for my workflow.

Thank you all, still great stuff, and i’ll probably end up with a Maestro in my setup, but that won’t happen for another few weeks until payday, which I will lose for constructive work with the Aeros. I would think that you would refactor and harden MIDI implementation on Aeros for a point release - soon?

PS - I rewired the rig, put Aeros downstream of BB as a Receiver. BB works perfectly, but same issue still present on Aeros - and I’m running Aeros 5.1.1

Hey there,

This is because the Aeros requires a steady stream of clock to stay “solid”, Logic (and all DAWs) only send clock while they are playing back, stopping or breaking this flow will mess with the clock being read on the Aeros

Try setting some bars of silence to loop so that you can have the DAW playing back and the Aeros receives steady clock even when the DAW is not recording. Turn off the looped section when you’re ready to start recording to the DAW

Let me know if this helps!

Thanks for the question