Aeros Not Connecting to Your Wi-Fi Network Using WPA3 security? Here's the workaround

Didn’t see this topic addressed anywhere so posting this to save some folks some time and potential frustration. :sunglasses:

Received my Aeros Loop Studio yesterday, but my excitement soon became frustration as I could not connect it to my wifi network. Every time I entered my password, I kept getting an “Invalid Password” error.

All made worse because I have a super long, random-character password. (Silver lining: I typed it in so many times, over and over, on the Aeros’s small touch screen that it’s now memorized. So…thanks? :rofl:)

In my troubleshooting, to confirm I was not mis-typing my wifi network’s password, I even went to the length of changing my wifi password to “Password”, and still got the “Invalid Password” error!

After two hours searching this forum and the Internet for solutions, I remembered I recently upgrade my wifi router to a WiFi6-enabled mesh system with WPA3. Wi-Fi Protected Access, or WPA, is a security standard for wireless networks. WPA3 is the latest, most secure wifi standard. You can learn more about it here.

WPA3 is a relatively new security feature. At the time this post was written (May 2021), most PCs, tablets, smartphones and Wi-Fi-enabled IoT devices do not support WPA3. The Aeros Loop Studio appears be one of these devices, too.


  • Set up guest wifi network - If you don’t already have a guest network set up, you’ll need to set that up on your wifi router.
  • Set the guest wifi network’s security option to “WPA2” - For my router, the setting is “WPA2-PSK [AES]”. It may be slightly different on your router, but should start with “WPA2”. Your WiFi6-enabled router should allow you to keep your primary network secured using WPA3 and your guest network secured using WPA2.
  • Connect the Aeros Loop Studio to your guest wifi network.

Once I did this, it was smooth sailing.


Thank you! Sorry you had this issue in the first place, but we could maybe improve this. Until then, we can add your solution to the manual!

Appreciate it :slight_smile: