Aeros not saving

My new aeros seems to be broken. It will not save any more or delete tracks. I finally got it to save more than 1 bar of sound when plugged into the beat buddy by not trying to record the drums from the BB but now it won’t save anymore… I have only had it 2 days and I am very disappointed… Nothing I have done has been saved https://youtu.be/OoDZmJYgq2E

@middlecut What firmware version are you using?

Having the same problem, 2.8.2. Received the loopstudio, updated to the latest firmware, been stuck since, cant save or create a new song. Diagnostic/download keeps failing. Is there another way to revert the firmware or reinstall it?

Singular Sound is aware of the issue. They’re working on a fix. I’m having the same experience with the LoopStudio. No waveforms will save but the name, tempo and mode do save. It won’t save recorded sound. I have not tried the diagnostic download yet. I will attempt it tonight.

If that doesn’t work, then we’re in the same boat. Let me know if the download works for you. Guess ill just wait on the fix.

Same problem here. Received yesterday. Updated firmware. Won’t save a song.

Just tried the diagnostic download to no avail. I attempted several times but the server times out. It’s going to be a waiting game until the developers fix it. Soon I hope!

I’d have waited another month for it to come ready to than to have it and not be able to use it. Leave a bad taste, you know. Sitting there all nice and awesome looking next to my mixer. Just dead on arrival. Everyone says the devs are working on a fix, but i cant find the post that says “Hey guys, we know of all 37 issues, we’re working on fixing them, sorry”.

1 Like

I’m having the same problem, loops just disappear after i save, 32 sd card in doesn’t help.
Thing is i’m a working musician so I can’t use this pedal until everything promised is working.
Would love to be able to call up loops as I scroll through my BB seamlessly with just pressing the BB.
If I can’t get it to do this I will have to look for ways to add midi files that I can record like bass and rhythm guitar and load them up to the BB as I call up songs on my setlist.

So just an update… I seem to have a possible fix. Switch it off and then hold down all buttons and turn it back on. Mine did a reboot or 2 and then the saving seems to work again although things are a bit slow to load. After speaking with support, this is not an official fix but it seems to have helped me. I hope this helps someone out there.

Hello everyone. We are working on a fix, we will have a new firmware update (with this fix) by the end of the week, according to our programmer’s estimation.

1 Like

Thanks J

I can’t wait for it to be able to save… I got mine yesterday and made some cool stuff figuring it all out so far… but then I switch to something else and Poof! It’s gone…

Ok, By connecting AEROS to my PC I can’t transfer the songs and I do not have the possibility either of backup on the SD card (32Go).
En connectant AEROS à mon PC je ne peux pas transférer les chansons et je n’ai pas la possibilité non plus de sauvegarde sur la carte SD.

1 Like

An anglais, s’il vous plait. So that our users and developers can help you, please post in English.

New update seems to have fixed the problem, loops are saving now so I’m going to add rhythm guitar and bass lines.
Is there a way to scroll through the loops as I scroll through my setlist on the BB? I currently scroll through with the SS footswitch, would be great if the Aeros saved songs/loops would follow as i scroll via footswitch. This way I wouldn’t have to bend over to select songs on the Aeros.
If this can happen the Aeros would be perfect for giging with.