Aeros seemingly not responding to Midi from MC6

Recently purchased Aeros and am having some erratic behavior with midi and wondering if anyone can offer some advice in order to diagnose.

I am attempting to use the Aeros with a Morningstar MC6, connected via Midi din cable.

I was able to get the Aeros to respond to some midi messages (ie: go to song list, go to settings, create 2x2, among others) at one point, but at some point the Aeros has seemingly stopped responding to midi commands and I’m not sure why.

I’ve confirmed that the midi loop diagnostic passes when din cable connected to both in and out.

I’ve confirmed that I have the MC6 Midi OUT connected to Aeros Midi IN.
I’ve confirmed that (at least using it’s own midi and activity monitor) that the MC6 believes it’s sending the midi commands correctly.

I’m using CH 1 from MC6, so also tried changing the setting on Aeros from “All” to “1” on the midi chan setting, but that had no impact.

Any advice welcome, perhaps it’s user error, but cannot figure out how to diagnose at this point from the Aeros side, so I can try and figure out if this is an mc6 issue, aeros issue or something related to the combo, or simply user error in terms of setup.

Thanks for any guidance

Aeros firmware version?

4.1.5, updated via wifi immed after purchasing the unit recently

Do you have another midi cable you could swap out? In Settings is your “Midi In Start” set to both Record and Playback? “Midi In” Channel 1, “Midi Out” Channel 1? This is my setup with the same firmware. I can’t think of anything else.

Thanks. Yes, have confirmed each of these while trying to figure this out and also just re-confirmed all these settings and a different midi cable, no luck.

As far as I can tell, the MC6 is sending the correct midi commands.
I don’t do a lot of midi so don’t have many tools here, but did check by connecting the MC6 to my iPad and running the Midi Wrench app and it appears MC6 is sending the correct info out, as far as I can tell.


@dbmdbm Out of curiosity, did you make any command changes to your MC6? I’m not very good at midi, but I found sometimes, when tweaking commands the MC6 wouldn’t work after that. I had to do a factory reset and reprogram it all over. When I did that, it worked perfect.

Hey, thanks for the tip. Can you provide an example of a command change that you made that caused instability on the MC6? Want to make sure I understand what to look for.
I’m leaning toward thinking this may be an issue on the Aeros side, but want to look at what you’re suggesting (and any other suggestions that surface) before making a conclusion. Thanks


Using the Morningstar software editor I changed which switch did what (I can’t tell you specifically-sorry). Anyway, a few times this has happened. I don’t know which device is to blame. Knowing me, it could be used error🤣. I will say clearing the MC6 (factory reset) cured it.

Unfortunately, this is not being reported or reproducible on our end, it may be something related to your MC6 or a bad cable!

If you’d like you can reach out to for assistance here

1 Like