Aeros software update working?

I have connected to WiFi but when I go to updates it says I am not connected. Is this working for everyone else?

I noticed the same thing. I switched to the WIFI screen and it shows I am connected. Went back to the Updates screen and the Not Connected status is no longer displayed.

I think it takes a few seconds for the Updates to find your connection and once it finds it, then it displays.

1 Like

Are you going shortly after startup/connecting or giving it a few seconds as persist mentioned? We tested all the units to ensure that wifi connection and updates worked before sending them out, and I personally don’t notice any delay between connecting and that not connected status no longer displaying, but potentially internet speeds play a role.

I’m not familiar enough with the mechanic to say for sure, but I could easily see it being a case where it sends a test packet or pings the server to ensure it’s able to connect to it (independent of connecting to wifi) and thus if the internet is a bit slower takes a few moments to confirm that connection. I know we’re on fiber optic here so it’d make sense if we don’t see that for our units.

1 Like

My Aeros said “not connected” until a new firmware version was available, then pressing update installed the new version.

I’m trying to update my Aeros but having no luck. I have a strong wifi signal where I am using my Aeros.
My Aeros is displaying software version 2.2.0 and it also says “All up to Date” which is incorrect. Is there any other way to update the firmware/software other than by wifi?
In the diagnostic screen it fails downloading the “Aeros wifi test file.bin” due to the connection timing out. It also fails the midi self test. The only test it passes is the Blue Tooth self test. Do I have a bad unit?

Probably not a bad unit but more likely you’re not connected to the internet. Try reconnecting your Aeros to WiFi making sure you’re entering your network userid and password correctly.

To test your MIDI, connect a single MIDI cable to the In & Out jacks on your pedal and then test. It should work.

If this still doesn’t work, contact

EDIT: I can’t connect to the Download site for the test file either.

Is there a way to side load the update?

Download on a PC and update via USB or sdcard?

Yes, if you email our support at they can walk you through that process.

I switched mine off and then on again and it connected to your site and loaded the update. Thanks!

I tried loading up a sd card as anthony suggested but the page wont open. Anyway i decided to bring the Aeros down close to the router so it will load up right/quick.
It says download successful so i’ll report later.
Fingers are crossed.

1 Like