Aeros stuck in a Boot Loop

I switch on Aeros, it loads to the main screen then reboots, repeating this process for about 5-10mins until it finally stops.
Has happened every single day I’ve turned it on since updating the firmware and I’ve had it less than 2 weeks.
Seems to do it whether an SD card is inserted or not.
I’m returning it for a replacement but I’m wondering if anyone has had this issue before?

Have not read about this issue. If you have not done so yet, try this

  • download the firmware update to your computer,
  • unzip,
  • rename file to aeros.bin,
  • copy to unlocked SD card,
  • eject SD card from computer,
  • with power off to looper, insert SD card and power on to looper

Yes please try that^ and if not please be In touch with!

Seems it was the power supply. Took it back and tried my unit with a (previously) unopened units power supply and that worked. My old power supply failed to even boot the unopened unit. So I’m home with the new power supply and hope all is smooth from here-on in.
Do you ship country specific power supplies or is this the job of your distributor? Am in Australia.

This was the Aeros’s own supply you were using?

It sure was.