Aeros won't turn on after firmware update

Greetings! Today I ended up in a sad situation and looking forward to some help. I haven’t updated Aeros for quite some time (I think for over a year) so I decided to do an update. As far as I recall, firmware version that I was at before the update was 3.03.

I connected to WIFI and initiated update process. After the firmware was downloaded, the update started and then a message like the following occurred: “Wrong firmware version. Retry.” (I don’t remember exact words, but it was something like that).

I clicked retry button and I think I returned to the main menu without an update. I returned to the update menu and saw the message “up to date”, which I guess indicates that there’s nothing to update.

I decided to re-start Aeros, so I pushed the button at the side of it. And it was the end of it. After turning it back on the device keeps making clicking noise as if the power tries to start it up, but nothing happens.

Can someone please advise on whether it’s possible to reanimate the device? I haven’t actually used it for quite some time but still it was always in my chain in bypass mode. Now it cannot even do that, sadly.

Here’s the video that describes the issue better:

Try disconnecting it from the power source and let the pedal sit for 5 minutes and then try to see if it will power up. If it doesn’t, try the next step.

Have you tried using the SD card method? It might help you restore the AEROS.

If it doesn’t work, contact for help.

Here’s the SD card update instructions:

Thanks for the quick reply. The first method didn’t help, same issue. Will try the method with the SD card and report back.

A small update. After leaving the pedal off for a day I was finally able to turn it on. And after that I was able to download the latest firmware which was successfully installed on the device.

However, after that I decided to re-start the device and check if the issue is still reproducible. I re-started the device with the side button and, sadly, same issue occurred: the pedal keeps clicking but won’t start.

Reanimating Aeros with SD card method also didn’t work: the device won’t start neither with a card nor without it.

As you pointed out, will reach out to support team via email.

Thanks for the update. Please make sure that you are using the power adapter (PSU) that came with your AEROS. Some users report problems with third party PSUs not powering their AEROS up at startup.

Let us know how Support helps you resolve your issue.

Update #2:

After playing around with a different PSU I managed to get Aeros working. So looks like it was a power issue in the first place. Considering this issue resolved. Sorry for troubles.

However, need to point out that Aeros is extremely sensitive to power source. After buying it I had to switch from a cheap Chinese PSU to a rather expensive Zuma from Strymon (there’s actually a thread that I started about a year ago here). All of my other pedals were happy with the previous PSU. And now Aeros is no longer satisfied with Zuma either, it works ~50% of the time with Zuma and 100% times with the power that came with Aeros (again, all of my other pedals are totally fine with Zuma).

Just food for thought. Maybe you guys can look into this in your future Aeros iterations, I suppose this cannot be solved on the firmware level.

Anyways, love your product, it’s still great. Cheers!

1 Like

Glad you’ve sorted it out and thanks for keeping the forum updated.