BB and Aeros Sync issues

I’ve been constantly having the issue of the Aeros and Beatbuddy not syncing. I spent days working on my set and tested everything before I left for my gig last week. Everything worked fine at home. I got to the gig and pressed start and the Aeros started but the Beatbuddy didn’t. This happened two gigs in a row btw. I powered everything down several times and eventually had to just use the Beatbuddy as a drum machine. Very frustrating and embarrassing when this happens on a gig. I’m really very disappointed with the products at this point.

Go to Aeros settings> Midi > Midi Out. And check if this is to “transmitter” to have Aeros as Master
Scroll down
Set “Midi Merge”
Transition “On”
Start “enable”
Stop " enable"
Start 1 recording “rec start” this start the Beatbuddy immediately when you hit the record switch (take car No intro on the BB for this
Midi Outro “Enable” if you want the Beatbuddy playing the outro at the last measure before the end of the loop

2 Likes

Hi NigelOxide,

To address the syncing issue between your Aeros and BeatBuddy, please send us an email at support@singularsound.com with details. Providing a video and steps to reproduce the problem will help us assist you effectively.

Thank you for reaching out, and we’ll work to resolve this together.

1 Like

Will do. It’s not working at all now. Stopping in the middle of playback etc. It’s 2am right now and I’m frustrated. When I get some sleep and a clear head I will send videos.

1 Like

Who is the master ?

I AM (maniacal laughter) Just kidding. The Aeros is set as the master. Everything was working fine until I updated my project after adding some fine tuning to some of the songs.

1 Like

What do you see at the bottom left of the screen ?
The tap tempo or the next part ?

Could it be a power issue? I had a gig last Friday and tested everything before I left once again but when I got to the gig it wouldn’t sync once again. As the night went on it started to work but weird things happen like the tempo not being consistent etc.

Please take a look and let me know

On songs that I’ve preprogrammed it says select part. Songs that I create on the spot it shows tap tempo. I’ve taken pics of how it looks. As I said everything works fine at home. The minute I get to my gig it goes haywire. In these examples everything checks out. Plays back correctly.




Hi Nigel,

I see that you’ve reached out to us at support@singularsound.com. Let’s continue this conversation there to address your problem. Thank you!

Confirmed it was a power issue at the show yesterday. Switched outlets and everything worked like a charm. My bass player and another friend suggested it was probably a power issue since everywhere else I used it it worked. The gig venue was the only place where I was having trouble.

1 Like