BB and soundcard midi connection to DAW

I have the BB and infinity looper , everything it’s fine but I wish to have also my DAW (cubase) synchronized as a slave with BB to be able to record loops on my DAW as i do on the looper.
I’m new to midi and I’m wondering if someone can help me to do that.

My problem is that if I connect the BB in the MIDI IN of my Focusrite and the Focusrite MIDI OUT to the looper then I loose the synchronisation between the BB and the looper, which instead I have connecting the BB midi out straight to the infinity, and also I don’t know how to synchronise cubase to the BB.

Basically what I wish to do is:
looper and cubase

Does it make sense?
Can someone help me to do that?

I don’t have a focusrite but it seems that it might not send MIDI data out of the box and you need to enable it using the focusrite control program:

1 Like

Thank You ghostofweedon but I’ve read that and I’m already using Focusrite Control and there’s not any mention about midi there.
When I plug BB , MIDI is shown on the soundcard, I can see USB MIDI in cubase but I don’t know how to synchronise with BB and also the looper connected Focusrite is not synchronized from the BB.
I also done a reboot of the Focusrite as suggested somewhere else.
I don’t know if I have to configure cubase or what

Hey there, this is going to be a setting somewhere, either in your interface or in your DAW where you allow passthrough of MIDI messages (MIDI Thru). The Aeros currently responds on ALL MIDI channels.

1 Like

ok thank You
I can’t find anything in Focusrite control,
I will try to learn how to do it in cubase

1 Like

I was in the same situation months ago and here’s how I set up mine. Hope this helps!

REAPER - DAW I use and set up as MIDI master, it controls tempo on both BB and VL3 (looper)
BB - set up as MIDI slave, tempo/clock is controlled by DAW, MIDI Out setting is set to MIDI THRU
VL3 - set up as MIDI slave, tempo/clock is controlled by DAW
ZOOM U-44 Audio Card

U-44 MIDI Out --> BB MIDI In

1 Like

For what I found in the Cubase manual is not possible to set cubase as a slave to midi tempo,
btw I’m not able even to configure cubase as a master and BB slave :frowning:
I will try with Reaper with your setup,thank you

Hi think It’s possible to do the same in cubase but unfortunately I’m not good to find a way

My purpose it’s just to make my daw to record while I start BB as the looper do

I will try with Reaper with your setup,thank you

I’m trying Reaper

BB as a Slave, I can start or stop recording when I press record on Reaper
BB as Master, I can see a led starting to blink as soon I start the BB and I’m able to record a midi track from BB but not play or stop in any device.

Can I ask you your Reaper settings ?

I wish to record when my BB verse or intro start

There are some synchronisation settings SPP,MTC ecc but I don’t know which one is the right one
I’m definitely going nut :grinning:

Now I find a possible way to do it , BB as a master in Reaper.
In menu ACTIONS apparently I can assign a midi note or command to every single action in Reaper which it’s great but I’m not able to assign a midi CC , the box it’s gray, I tried to put a midi note to Record and it is working but of course only when Reaper read that note.
How I can let Reaper understand CC commands coming from BB?

Here is my set up to record audio coming from BB in to REAPER as MIDI Master.

U-44 MIDI Out --> BB MIDI IN
U-44 Input 1 <-- BB Audio Out (Left)
U-44 Input 2 <-- BB Audio Out (Right)


  • set up as MIDI master, in REAPER Options / Preferences / Audio / MIDI Devices / MIDI Output settings (see screenshot below), Enable Output and Send Clock to Output
  • Track 1, input assigned to U-44 Input 1 and 2
  • when Record/Play button is pressed in REAPER, BB plays back the current song starting with Intro (if enabled) then Part 1. It records BB Audio intro REAPER Track 1 (Record Arm is on)
  • Syncs up the tempo from REAPER to BB


Here is my set up with BB as MIDI master and REAPER as slave:

U-44 Input 1 <-- BB Audio Out (Left)
U-44 Input 2 <-- BB Audio Out (Right)


  • set up as MIDI Slave, right-click the Play button in REAPER (see settings in the screenshot below)

  • in REAPER Options / Preferences / Audio / MIDI Devices / MIDI Input settings (see screenshot below), Enable Input

  • Track 1, input assigned to U-44 Input 1 and 2

To record in REAPER

  • Record Arm track 1
  • Click the Record button in the REAPER transport bar, a pop up message window comes up waiting for BB timecode
  • Step on the BB pedal, it will start recording in REAPER

Thank You very much ,your help it’s much appreciated.

After a big fight with almost every DAW around I finally found the free Cakewalk by band lab can be slave of the midi clock and when I press RECORD Cakewalk wait while BB is in intro and it start recording when the verse start and close the recording when BB stop.

I will try on Reaper to do as you wrote me

I got it! My mistake in Reaper was “Enable+Control” in MIDI hardware settings

It start to record with verse but it doesn’t stop recording as Cakewalk does but it’s not a problem

1 Like