BB Firmware Update - Access Settings

Hi everyone I updated the BB Firmware to the latest version last week and now can’t turn off the visual metronome which is now on by default Settings > Main Pedal > Visual Metronome.

When I push the Drum Set and Tempo together to access the settings all that is coming up is the Drum Set list, I have tried 100+ times so it can’t be that I am not quite pushing the two buttons together.
I want to turn off the Visual Metronome, and for what it is worth the Visual Metronome should be off by default and turned on if you desire - just my opinion.

Ok so is anyone else experiencing this and is there a way to fix this issue?

Does the Tempo button work when pressed alone?
Reinstall firmware version 1.8.5 again; once complete, power the pedal off and then back on.
If this doesn’t work, you could try reverting to firmware version 1.4.1 and reporting the issue via e-mail to

Yes all the buttons work as they should just after the update I can’t access the Pedal Settings. I will update again and see what happens…

Were you able to access the settings in the past? If all the buttons work then it should go into the settings menu by pressing them both down. If you are not able to, send me an email.

Thanks I have sent you an email to also

Although I think the older support address will still work, they now have a new address :oops:

Did you get this issue resolved. I am experiencing the same … latest firmware update 1.85

Correct, we updated our email addresses as we’d want people to know our company name especially since other products (such as the looper) are in the pipeline. If someone sends an email to our old email addresses, it will still get to us. :slight_smile:

Not yet. I’d like you to downgrade to 1.41 and see if you can access the settings in your BeatBuddy and then back to 1.85 again to see if the issue comes back. I would just like to pinpoint whether or not the issue is coincidental or directly related to the firmware version 1.85 - and this would be the way to find out. Here is version 1.41:

The above is also what I instructed to @57Strummer and we will see what happens on his end.

If both of you have the same results, we will have a very clear indication as to what the problem is. If it’s a firmware problem, we will get on it right away. If it’s a physical issue, we will replace your units.

Wow awesome to know a looper is in the pipeline- hopefully it will be a small footprint and have 2-3 or more loops that can synch with midi functionality of course. :slight_smile: