Beat buddy stuck in stopped state

I have a new in box beat buddy. I can’t get the beat to start. No matter what I click on the pedal the screen stays on stopped. Is it possible to get this think in a locked state where it will not play?
Thanks for any help

Does anything show on the pedal display and if so, what? Is the unlocked SD card in the pedal slot?

Press the Tempo and Drum Set knobs at the same time and release. Can you navigate thru the settings to identify the firmware version—what is it?

If you have a remote foot switch, plug it in and use the settings from the pedal menu to run the pedal detection; does it prompt you to Press and Release the left and then right switches?

Yup the pedal display shows everything I would expect. The only difference is that it continually shows as “Stopped”. I can get into the settings menu no problem. Firmware was updated to 3.8.0. I do not have a remote foot switch in it.

Thank you for taking the time to respond to my question. I’m also working with singular sound tech support. Will keep the thread updated with findings…

1 Like

Oh I should also mention i’ve put the SD card into the beatbuddy manager. All the beats play fine. Its just on the pedal that they don’t play. I’m almost thinking the pedal is just faulty. Like maybe the trigger isn’t working.

In the interim while you wait for Support, you could try this: download a fresh copy of the firmware, unzip and copy the files to the SD card (inserted in your computer); power the pedal down, insert the card and see if that helps.

It does sound like you have a defective pedal, though. Good luck getting it up and running or replaced.

OK just tried reformatting and re -copying files to the SD. Same results. I will head of to GC and see if I can get an exchange.

You might want to test the replacement pedal before you depart GC. :thinking:

It could be a faulty main switch, you could test it by opening up the BB and see if the connection of the switch is still in tact or got loose. Maybe connect the two wires to simulate a pedal press and see if it starts the beat, then you’ll be sure it’s the switch. If it is still under warrenty sort it out with support.
If not it is worth a try. (The switch can be replaced with any momentary switch that will fit the space, just resolder the two wires)

I was under the GC 45 day return policy. So I took it back and ordered another one. Will test the new one before I leave the store.


Just purchased mine and this is where I’m at too… How did you resolve this issue?

According to his replies above, he did three things

  1. notified and worked with Support, support@singular
  2. downloaded and reinstalled a fresh copy of the firmware
  3. took it back to Guitar Center and exchanged it for one that worked
1 Like

Persist is correct. My situation ultimately came down to a DOA foot switch on the peddle. I did exchange for a new one. Been using the new one every day since I received it. :slight_smile: