Beat Buddy to Infinity Looper, Loop Playing back at strange speeds

Hello All,
I have been researching this for hours, I have been all over this forum and I have not found a solution. I may have missed it so please forgive me for beating a proverbial dead horse.

Beat Buddy Version: 3.8.0
Midi Out Settings:

  • Output type: MIDI-OUT
  • Channel: 1
  • Sync: Always On (I have tried While Playing)
  • Start: Main Beat
  • Stop: Pause and End
  • Notes: Disabled
  • Next Part: Enabled
  • Time Signature: Enabled

Infinity Looper Firmware: 218
Reset to factory settings

When I try to sync anything with the midi cable plugged in the Looper responds with a very slow pitch downshifted loop or a really crazy quantized slow loop. I do not have an expression pedal. I have tried two different cables and I have metered both cables to verify that they have connectivity on all 5 pins.

I am at a loss to what is wrong here. It is almost like the clock is only being read every other beat. Any direction will be appreciated.

Here is a video of what this sounds like. https://www.dropbox.com/s/z1950nmr8p3gs4i/IMG_0109.MOV?dl=0

https://forum.singularsound.com/search?q=Varispeed This link might help with your issues

Thank you persist. I thought it was a Varispeed issue, but, if I unplug the MIDI cable the pedal will record loops like normal, is it possible the BB is sending the Varispeed Midi message. On a side note, who would use a varispeed feature on a loop pedal anyway…?

It seems you’ve pretty much got the settings on both pedals applied correctly. Just double-check against the screen shots to see if you missed anything on the Infinity side of things:

I don’t have the fade length setting or “ignore midi clock” but those are both not checked so I think that is okay



Here is another video showing that this only happens with the beat buddy clock.https://www.dropbox.com/s/vk8u098s96zyzdp/IMG_0112.MOV?dl=0
The second part gets a little loud as the loop gets quantized again.

Another note to add. The arm light does not ever flash in time with the BB, it flashes at completely random intervals.

Hi,
Exactly the same problem for me… same settings.
I tried nearly everything, no solutions…

I reached out to Sweetwater tech support and they are assisting with communications with Pigtronix. We did try a firmware update today to no avail. I will respond to this thread if there is any solution. If not I plan to buy an Aeros and be done with it…

well, I digged everything on internet dor days, tried nearly everything, bought a new expression pedal to try to solve the varispeed/tempo problem, bought new midi cables…no solutions…
I asked both Pigtronix & Singular sound for help but no real efficient reply. The only solution i found was to work both devices without sync… which is a joke because if you buy these 2 devices it’s because of reputed efficient good sync…
It’s a pity as I only bought these two devices as they were advertised to be the best looper/rythm box to work in sync. But finally not.
I personally feel cheated.
My conclusion: I suppose as both Pigtronix & Singular sound recently developed new products (Beatbuddy mini and Infinity 2). They don’t seem to really care to solve bugs on old products.

Next time I will buy bigger brands like Boss or Digitech. It’s more secure.

Sorry you’re still having sync issues with your BeatBuddy (BB) and the Infinity. About all I can say is that the solutions I offered in my posts above came directly from Pigtronix and Singular Sound and although other BB and Infinity users had the same issues as you have, many (who knows, maybe not all?) were able to successfully resolve their problems and are still using the two pedals as I am.

Hi,
I recently bought a beat buddy drum machine and infinity looper after hearing about how they integrate well together with the midi sync. I haven’t been able to get them to cooperate as advertised though. I’m running into a couple of issues:

  1. When I have the BB and Infinity connected via midi cable, every loop has a very prominent volume/pitch warble. I recorded a very short video just looping a single note for demonstration: https://youtu.be/ewCY6b3uo6g

  2. I haven’t been able to get the infinity to respond to the Start command, so I have to manually start recording after the bb plays

Both pedals are updated to the latest firmware version, so any other guidance you can offer is greatly appreciated!.

There are several threads and posts addressing this issue. Please use the forum search function and you’ll find at least one as recent as today.

Later today I will merge your post with an existing thread. The takeaway is to search the forum before starting a new thread. Appreciate your consideration.

@persist I did search before posting, and never found any mention of the warble and none of the suggested fixes seemed to help. I understand that midi sync issues in general are common, but this particular manifestation seems unique. I’d appreciate reopening the thread if it’s not too much trouble!

Sorry Persist, it was not intended against you and I noticed all the hard work you did to find solutions and help along this forum. I am simply desperate in trying to fix this sync thing as I spent around 800 euros for these… Thanks

just found a solution for this pitch problem: set sample rate to 12khz in Infinity looper software.

1 Like

Can you please post screenshots of all your settings for the Infinity? I just did this and the warble did indeed stop but it is still not synced.

Thanks,
Nick

Hi Nick
I don’t have my devices with me at the moment. But what I can say is that your beatbuddy presets are correct.
About the infinity presets you can use the screenshots provided by Persist except that you have to modify the « default sample rate » mentioned in the infinity software main window to 12KHZ. You have to do that preset by preset.
Let me know how this works. If my explanations are not clear I will provide you screenshots tomorrow.

Thanks Nicof, I gave it a shot but it did not work for me. The pitch warble did stop which is great! But, there is still no sync working. The Arm light is still flashing on its own beat. I am happy you fixed the problem for you though, switching the sample rate was not even something I had considered. Take care.

Just wanted to give a final update for anyone else experiencing this problem. Pigtronix responded to Tech support at Sweetwater and recommended that I send it in because there is a ‘problem’. No real explanation of the problem but it is indeed broken somehow. I went ahead and bought an Aeros and I could not be happier with it. I will get the Infinity Fixed and keep it as a backup maybe. If tech support at Pigtronix can make it work correctly with Midi I will return to this thread and let you all know how it worked out. Thank you all again for your help.

2 Likes