Beat Buddy to Looper - Midi message sent once every bar?

#1

Sorry if this has already been covered but I couldn’t see it;

I was just wondering if it’s possible for the Beatbuddy to send a midi sync message to my looper (Boomerang III) once every bar? At the moment it sends out messages every quarter note and I, personally, would never need it to sync on the 2nd, 3rd or 4th beats of a bar (in 4/4 time).
I can sync it on the start of a bar ok but it would make life so much easier (especially in a gig situation) to have the option to set midi messages to once every bar. That way, much like the way the BB fills work, you could tap the looper record button to end recording any time during the bar and not worry about yourself accidently ending it on the 3rd or 4th beat which would send it out of sync - absolute car crash territory in a live situation!
Is there an option to change the time signature to 1/1??? :lol:

Once again, sorry if this has been asked.
The BeatBuddy is amazing by the way - love it!
Cheers!

#2

No one else would like to have the option to have a midi sync message sent out once per bar (or other configurations) from BB to looper rather than every quarter note?
If I’m being silly and have missed it in the instructions and you can already change this then let me know please, but if it’s not a feature I would’ve thought it would make live looping performances a much more intuitive and relaxed affair.

I can’t be the only one!

#3

I have an Infinity looper and depending on the looper configuration, it will start/stop recording either at the start of the bar, immediately, or on a chosen beat, depending on how I set it up, so the BB doesn’t really control the looper, it’s just a clock. I imagine the Boomerang can be configured the same way.

#4

No, you can’t setup Boomerang III as you can do with Pigtronix Infinity (and it’s a huge plus for me, to be honest). There is at least one problem that is specific to it - http://mybeatbuddy.com/forum/viewtopic.php?f=18&t=823#p2613.

You actually have two options here.

  1. Really make all your songs 1/4. This is unforgivably hard, error prone, unrewarding, time consuming and not fun task at all. So I wouldn’t even suggest doing that. You will have to go through all the song parts, and make the 4x faster. This will, however, really make your Rang III to
  2. Work on your Rang timing a bit. I’d even suggest you unplug your MIDI cable at start to feel the difference. When you plug a MIDI cable, you will feel syncing is much much easier.
  3. Make use of the Master Sync mode of Rang. If you are really struggling to press Rang in due time (like option 2 is not an option for you), consider recording one silent bar to Loop 3 of Rang (only works when no other loops are recorded). All other loops (1, 2 and 4 if you enable it) will start exactly when a new bar starts no matter when you press the pedal (just as you want).

You may watch my video in the signature once again - I am using that trick there. I record a small two bar “backing track” of three chords onto Loop 3 that then plays through all the composition.

#5

Cool, thanks for the valuable info guys.

Daefecator, That 3rd suggestion is genius - can’t believe I didn’t think of it! I was using that mode all the time before I got the BB. That effectively does exactly what I was asking for - sets it to a bar sync so I can cue up parts anytime during the bar.

I’m pretty good with my timing, it’s just when (in a live situ) you have your foot hovering over and very occasionally you might just glance the pedal when you didn’t want to - this should, in theory, eliminate any chance of the ‘out-of-sync-absolute-car-crash’ scenario.

Off to do a local pub gig now so this info I will be using tonight!

Sorted - thanks mate! :smiley:

#6

You are welcome!

Have fun tonight! :slight_smile:

#7

Scudd,
I just got an Infinity Looper and am struggling to start/end record at the right point in the BB measures. Doesn’t seem to be consistent and I don’t think it’s my timing. Can you please describe how you can choose the options you describe above in the looper? I find the looper software and the instructions very confusing. Thx so much in advance for your guidance!

Btw, I have latest firmware 152. And I’m a Mac user.

#8

jakecj69, are you sure you haven’t forgotten to connect MIDI Out of the BeatBuddy to MIDI In of your Infinity looper with a MIDI cable?

This actually happens to me sometimes when I play :slight_smile:

#9

V

Yes, I’m quite sure. I hope Scudd can share the settings he referred to on his Infinity Looper

#10

Ok, looks like I know what may be causing that. Wait a minute.

Are you using the most recent firmware?
Also, are you using one of the songs on this list - http://mybeatbuddy.com/forum/index.php?threads/some-intros-are-incorrect-length.582/#post-2095 ?

If that’s the case - update your firmware - it’s fixed there. MIDI Start should be sent after the intro - there’s an option in the pedal menu.

#11

Yes. All latest firmware on both units.

#12

Unfortunately, my pedal currently doesn’t run an official firmware, so I can’t tell you exactly where that setting is…

As far as I remember - press Tempo and Drum Set at the same time.
It should be somewhere in Main Pedal > MIDI Start (or smth like that).

Please search it, while I am nodding off to have some sleep.

#13

The manual says:

6.2 Time Signature
The Time signature can be changed, on a preset-by-preset basis, using
the Infinity Application. For quantization to the beat rather than to
the measure, set the measure to a single note (eg. 1/2, 1/4, 1/8,
1/16).

I can’t remember the exact location, but when you open each preset, there is a an option to for Quantization.

#14

Also, Infinity released some new Firmware with extra BB support:

December 16, 2014

Changes:

-Complete Beat Buddy support has been thoroughly tested and fixed where necessary. All incidental delayed behavior has been removed and the Infinity’s currently armed loop can be set to record (if it has no recorded audio) when a MIDI Start is received. This setting is under “Tools->Global Boot Settings->MIDI Start Records.”

#15

MIDI Time Signature box, you can set it to whatever you want. By default it’s 4/4. Set to 1/4 for quarter not, 1/8 eight… etc.