Beat per minute jump

I keep having an issue where the beats per minute increase by one on the Aeros on various songs when I start the beat buddy. All my connections are proper. Any assistance would be greatly appreciated. Thank you!

Hi there, if you could show us a video of all the steps it take to reproduce the issue that would be helpful, thanks

I also messaged you privately about the same thing.

I already sent a video to support. And for some reason I can’t send the video through here.

No issue! You did what you had to do there, thanks!

What is your email so I can cross check with them, you can PM it to me if you’d prefer it private.

Not sure how to private message you but here’s my email:

Any assistance you can provide me will be greatly appreciated since I have a gig tomorrow.

1 Like

Just to let you know, I bought a new MIDI cable, a double check that both Beat Buddy and Aeros are up to date on their Firmware, but I’m still having the issue. I have a gig later today and 3 more this week. Let me know how we can resolve this.

I just bought this and this is gonna be the first time I use it live. I must say I’m a bit disappointed that this is happening. Please help.

You’ve probably already tried this and I hope I’m not muddying the waters so please excuse me if either or both of my assumptions are correct. Also, have you and Support been in direct communication yet?

If you are using BeatBuddy firmware 4.00(beta), try rolling back to 3.99 and testing it with the latest Aeros firmware. If you’re still having the BPM and gap issues, take the next step by also rolling back to the previous version of the Aeros firmware.

Click on Brennan’s avatar (to the left of his post) and press the blue message button.

I already tried it the 3.9 firmware with the beat buddy and it was still doing it. And how do you switch back the previous update on the Aeros? I haven’t tried that yet. And no I haven’t been in direct communication with support

Go to the first post on Aeros Firmware 4.0.x

  1. download the last official release of the Aeros firmware
  2. use the SD card update method as explained in that first post

Do I have to use a different SD Card or can it be the same one as the Beat Buddy? Can someone call me? My number is 305-965-7311

I take it you don’t have a separate SD card in use for your AEROS?

If your BeatBuddy project is saved within your BeatBuddy Manager (BBM) on your computer you can give it a try but first make sure there is no content on it. If there is content and your BB project is not in your BBM and saved in your bbworkspace folder, I would first copy the contents from your SD card to a folder on your desktop before deleting the contents from your card.

Hello again, I just saw the video, you may have misunderstood what I needed to see, I need to see what you do before you record the song to the Aeros. The Aeros cannot adjust tempos after it has been recorded to a tempo.

As far as I can tell from your video, you may not have let the Aeros set the BPM correctly. MIDI clock response is not great at reading immediate changes to incoming tempo. So, for example, if you are changing between two songs on the BB that have very different tempos without changing songs on the Aeros, the Aeros needs about 2-3 seconds to match the tempo correctly. If you were to start the Aeros too quickly, then the Aeros could still be calculating the changes in the MIDI clock and think it’s on a different tempo.

This can also happen if you are using tap tempo, the BB is changing it’s BPM and the smaller the change (and slower the BPM) the longer it takes the Aeros to sync fully. This is because the way MIDI clock works is the units are sending pulses and the amount of pulses in a time-frame sets the BPM.

From what I can understand this version of your recording is corrupted, the state it entered will not ever allow it to be correctly in sync. If you could please delete and re-record it, or start a new song, and make sure that you allow the Aeros time to fully be in sync, and then start the BB to begin recording. It should not cause issues if you follow these steps.

Does this make sense?

Then again, I didn’t get the steps you took to make this happen, so please let me know if something else is happening, and most importantly if you can reproduce it on a new song.


Hey so I actually found an extra SD card that was empty so I used that one. I got back the previous firmware and so far I recorded 9 loops with the beat buddy and it hasn’t done it anymore.

I’m going to keep messing with it to see if it’ll do it again. However, what’s going to be the final solution so I can update it back to the latest firmware? Will you be fixing it and letting me know?

Glad you’ve got an interim fix however, in order to answer your questions, you would first have to help Singular Sound out by addressing Brennan’s post (just above yours).

Yeah I’m aware that there is a 2 to 3 second change of the tempo. I usually wait 5 to 10 seconds to start playing my next song. And with the help of the moderator, I uploaded the previous firmware. And so far, I’ve looped 10 songs without any problems. My question to the moderator was since it seems like a software issue, what will be the final solution so that I can update the latest firmware again? Thank you so much for your assistance.

I understand what you are saying, but without seeing a video of how you are reproducing this bug, I cannot say that it is a firmware issue, it may still be user error.

If you would like me to reevaluate that assumption I need a video or at the very least all the steps to reproduce.

If I cannot reproduce it, it is likely not a bug related to the Aeros update. It very well could be a change in behavior as I described above, but this is not a bug and can be worked around by just waiting a bit longer for the sync to take full effect.

We will likely improve this as we go along to be smoother

No one else is reporting your specific issue and that leads me to believe it is related to what you are doing before you record.


I will be more than happy to produce a video for you and send it. I will do it as soon as possible, I have gigs the next 2 days.

However, I am doing everything the same and I have not had the issue since I downgraded to the previous firmware. The steps I take before doing a loop are the following. I look for a song on the BB and then I always wait 5 - 10 seconds before pressing the BB PEDAL. What I noticed on the 4.0.1 firmware was that right when I pressed the BB pedal the BPM changes by 1 beat per minute higher. I would then record my loop and end it. I would then play it and when it reached the end it would skip/gap for 0.5 seconds or so.

That’s pretty much all I do. It was always in 2x2

The SAME THING is happening to me. Recorded a song at 100bpm and then after save Aeros is saying 101bpm but BB has to play back at 100 or it gets off.

And the (deal killing) gap - in this case it’s 1 and 9/16 of a beat at 100bpm. Whatever that is in seconds.

BB to Midi Maestro to Aeros… All firmware “up to date” – alas…