Beatbuddy always displays 1-full measure of BPM after receiving ANY MIDI Maestro Command

I hesitated before posting this, but I cannot find a similar problem in the forum at this point. My problem is this: I have MIDI Maestro in Beatbuddy mode, controlling the Beatbuddy. EVERY time I issue a Command from a MM footswitch, the Command DOES get implemented in the Beatbuddy, but the BB always displays the large BPM screen (for an entire measure) before returning to its pertinent display (e.g., Playing or Stopped). ANY MM command - Start, Stop, Accent Hits, Next Part, etc - the BB does what it’s supposed to do, but displays BPM (and each beat) for a full measure before it goes back to its screen (e.g., Part 2/3). This happens regardless of whether the BB is Stopped or Playing.

It’s extremely annoying - ESPECIALLY when trying to use the MM to navigate folders - it’s impossible to navigate folders with the MM this.

In OTHER words, if looking at the following video starting at 1:18, every single time the narrator presses a button, the BB does what it’s supposed to do without also displaying its current BPM. However, MY Beatbuddy displays the BPM value FIRST (for a full measure) prior to being able to see that the BB actually responded to the button press.

Here are the technical particulars, along with things I’ve tried:

  • The MIDI Maestro IS in Beatbuddy mode
  • I’ve tried MULTIPLE MIDI cables from the MM MIDI Out to the BB MIDI In
  • The MIDI Maestro firmware is 1.1.7, and I’ve re-loaded the firmware multiple times in order to ensure that the firmware update process didn’t get screwed-up somehow.
  • I’ve tried multiple firmware versions on the BB itself - 3.9, 4.01, 4.12, 4.13 (current). I’ve loaded those firmware versions multiple times.
  • I’ve tried multiple SD Cards, including the original SD card that came with the BB.
  • I’ve used MIDI-OX on my PC to look at the MIDI output of the MM. I did this because I wanted to ensure that the MM wasn’t ALSO sending out a command for the BB to display BPM. I’m not completely fluent in all things MIDI, but I CAN see that when I issue a START command from the MM, MIDI-OX displays 3 packets - the controller command and 2 LSB packets (50 & 51). From what I can ascertain, this is standard behavior (but I could be wrong).
  • I’ve tried setting the BB MIDI In to Channel 1 (from its default of OMNI), but that didn’t change anything.
  • I’ve tried setting the BB MIDI Setting for System Real Time Sync/Start/Stop to Disable - no change.

I’m running out of darts to throw at the dartboard on this one. Has anyone seen or heard of similar issues?