BeatBuddy and Infinity Looper - problem with midi sync

Hi there,
First, sorry for my english. It’s not my first language.
Here is my problem.
When my BB is connected to Infinity Looper and I turn on BB’s beat my IL “goes crazy”. All the LEDs(STOP, ARM, REC), are blinking very fast. I can’t record any loop, I can’t do anything. When I turn off the beat, everything is back to normal. Midi clock works, IL’s arm LED blinks in time with BB.
When IL is not connected to BB, everything works fine.
I’ve updated software of both pedals.
Could someone please help me to resolve this problem?

Thank you,

Looks like it’s because the latest BeatBuddy firmware version started to output all MIDI notes. This is what drives your Infinity mad.
At this time I know no other workaround than to downgrade the firmware version back to when it didn’t output MIDI notes. You can download firmware version 1.4.0 from my Google Drive -

It is completely safe to update the firmware both ways, either upgrade or downgrade.
Use the usual instructions - unpack the archive, and place app.bin, MLO.bin and boot.bin to the pedal SD card and don’t power the pedal off until the update process is completed.

This should soon be fixed (if it is not already). I recall some user already got his hands to the 1.4.2 firmware, that fixed everything, but I personally don’t have it currently. I believe you can ask support for it via

Thanks for your help.
Your definition of the problem seems correct. Looks like my IL reacts to every note from BB.
However, I’ve downgraded the software and it didn’t resolve the problem.
I’ll ask for support, as you advise.

My IL works fine with newest update… In IL Application you can go to Tools / Global Boot Settings, there you can decide to “ignore Midi notes”, maybe this may help you out, using the last FU.
But somehow my IL works without ignoring Midi notes… I am on FU 1.41, am I missing something?o_O

Dennis, thanks a lot. :slight_smile:
I’ve changed IL settings and now everything works fine.

Glad to hear…:smiley:

Thanks everyone… This just happened to me recently when I upgraded my SD card on my Infinity. Was loosing my mind and couldn’t figure it out. All good now! Back in action!!!:smiley:

I tried BeatBuddy Manager for the first time. Updated Firmware, and installed some of the songs you good folks have posted. BB is working great, no issue. Infinity Looper has lost it’s marbles. Seems like the loop starts late, is a few pitches down, the loop is acting like it has slowed down. If I disconnect the midi cabe from the infinity it is looping in time. Anyone come across anything like this?

Make sure youre using right time signature (in Infinity application),
make sure BB`s tempo is the same as the recorded loop,
ignore incomming Midi Notes (alo in Infinity application)…
Hope that helps…:slight_smile:

Thank you Dennis. I wasn’t aware that the Infinity had an app. Following your direction (ignore incoming Midi notes) worked perfectly. I did struggle a little with how to save the change in the Infinity application (but even us old guys figure stuff out eventually :-)).
Downloading and trying out some of the programed songs with bass notes on the BeatBuddy I am myself lost in where to punch in and out on the looper. The programed songs work great, I just end up trying to loop a measure early or late. Not sure how to line this up, but will continue reading.
Great products, when I catch up with the technology I should be able to produce some great results. Cheers all, thank you for being so helpful as a community :slight_smile:

RoryPlog, I would love to know how you managed to figure out how to SAVE the changes in the Infinity application. I can’t work it out :frowning:

Hi Ethereal, sorry it took so long to get back to you. I really don’t have a clear process for how it saved. I made the changes and then ejected the pedal. I then plugged it back in and the changes had been saved. I’ll try to test this weekend and see if I can figure it out further.

Hey it’s no problem Rory. I worked it out. You don’t have to save! You just check the box and exit the app. Done! Problem I had was corrupt software that did not apply the change so a format and fresh install of the software got me up and running again. Thanks!