BeatBuddy and Infinity Looper Won't Sync

After working fine for several days and not changing anything my BeatBuddy stopped syncing to my Infinity. I have the latest firmware on both. Since this issue started I have subsequently formatted and reloaded the software from scratch on the BeatBuddy. But I still have no Midi Start or Stop commands going from the BB to the Infinity. I don’t get a midi clock either (tempo light not flashing on Infinity). I’m using the BB provided Midi cables and I’m connected to “Out” on the Midi Y cable.

I love these when they work but they are frustrating when things go wrong.

It sounds like the firmware settings on your BB might pedal have changed (this will happen if you export your project from your BBM to your SD card. Could you check the MIDI settings on your BB pedal? You can change the settings on the Infinity using Pigtronix’s app.
– press Drum Set and Tempo to enter the settings menu
– scroll to and select Main Pedal
– scroll to and select MIDI Messages
– select MIDI-OUT
– scroll to and select Sync
– change to Disable and back out of the settings
On the tempo light not flashing, I think this is “normal” for the Infinity when the MIDI-OUT Sync has been disabled on your BeatBuddy.

Thanks for responding. I did try that. It didn’t change anything.

What is the chance that the Midi cable is bad?

I’m strongly suspecting a bad Midi cable. I checked continuity of the pins on the cable. I’ve not worked with Midi cables before but I assume there’s a one to one connection between the pins. Checking with a DMM, I get continuity between 4 of the pins but nothing between one set (either end) of pins. I’m going to try a new midi cable.

That could be the issue. From what I can tell from the pinout, only 3 pins are connected.

Yes. I found similar information. On my cable there is no continuity between the #4 pins. I’m now leaning heavily towards bad cable. Because it’s Black Friday, I’m waiting until tomorrow to go to GC and get a new cable.

Thanks for your help. It’s very much appreciated.

Just got back from GC. The new midi cable solved the problem. I’m back in business.