Beatbuddy & Ditto X4 - How to get them working better

Got a Beatbuddy today and connected it to Ditto X4 and read most of the forum posts. This is what I did to get them working better together.

They sync well with Ditto X4 as slave, and provided you stomp the looper on the 1st beat to record and stop, you get a happy loop & drum combination.

Problem comes when you pause the Beatbuddy and try to restart. Again unless you hit the unpause button very close to beat of the midi clock (flashing in green above the Stop button) the loops will be in sync but out of alignment.

The problem comes from the constant midi clock output. If you turn that off except during playback things are better. Then if instead of pausing you stop the song - the midi clock stops (no green light flashing on Ditto). If you start the song again everything is in perfect timing. (For these tests I had Intros turned off).

So I have set one foot switch pedal to trigger an Outro rather than Pause/Unpause in order to stop the song and the midi clock. I restart the song with the main pedal and the looper starts it’s loops from the start in perfect sync.

I would like to see an option in Beatbuddy to end a song without an OUTRO or be able to stop the midi clock during a pause in playing. Either of these would make Ditto X4 and Beatbuddy relationships more harmonious.

1 Like

I wonder if some sort of mute pedal in between would be a workaround? So the beat is still playing in the background on the BB, just not being broadcast through the PA. Maybe and A/B box where B goes nowhere?

1 Like

I am sure I saw this (or a highly related) issue somewhere else, and it was resolved: you could either have the pause send a STOP message via MIDI or not (the slaved device would keep playing). Either way, the BB sends a START on unpause.

At any rate, check the MIDI options on the pedal, because you might find what you’re looking for there. The MIDI documentation lags a bit behind the implementation, I’ve found.

Thanks but that doesn’t work. The midi clocks needs to stop before BB send start signal and also starts the clock again. The problem is both with BB and Ditto. When the BB pauses it still sends out midi clock and when it unpauses it doesn’t start on the beat of the clock that Ditto is listening to (pulsing green light). Ditto for its part doesn’t reset its clock when it gets a start command.

I (think I) understand the problem, but, for some reason, I think I saw a solution on this board. If I find it, I’ll let you know. Meanwhile, maybe @BeatBuddy_Support might be able to chime in and tell me I’m wrong…


1 Like

This is the second report I heard of this. First one was from an Infinity, so this is likely something on the BB’s end. I need to look into this to see what is happening.

@MHMusic What is the firmware version on your BeatBuddy?

To check the firmware version, go into your settings menu (press down on ‘tempo’ and ‘drumset’ at the same time), then go into About BeatBuddy by pressing the ‘tap’ button. It will show you the version number on the second line.

The latest firmware version is 3.60 , and if you do not have it, you can get it here:

The version I have is 2.0.4 so I will download the latest version and see how it goes then.

So I’ve downloaded the latest firmware and still the same problem syncing with Ditto X4 after a pause. Works fine after stopped cause the midi clock stops too.

As a said at the top if you had an option to end the song instantly without an Outro (with the midi clock option to stop too) then it would fine with Ditto X4. I would like an option to end without an Outro anyway as often I like to stop the rhythm before the end play out a song with guitar and vocals only.

As well if you had an option to stop the midi clock during a pause then that would work too.

If your song has no outro, it stops at the end of the current bar. That’s as close to immediately as you’re going to get, I think.

So I looked into this, and we would need to fix this in one of the upcoming firmware updates. We added it to the list.


Thanks that would be great!!! :sunglasses:

Hi did we fix the issue with the ditto looper?

Has this been resolved? I am having the same issue and I have downloaded Firmware 3.8. I bought the extra pedal so that I could pause and am disappointed with how it does not sync with Ditto x4 after you unpause.

1 Like

BUMP - is this still on the “to do” list?