BeatBuddy Firmware 3.9.x "MIDI Optimizations and Bug Exterminations"

I have been playing with 3.9.3 for about a week now. Mostly it seems all ok but I find every now and then I’ll transition to the next part and the screen will display transition but then just stay on the same part. It is very random so doesn’t do it in the same places all the time. I’d consider myself pretty efficient in using the BB so I know it’s not when I’m pressing the button. I’m a little concerned that it is actually displaying it is transitioning but then just stays on the same song part.

As I said though, it’s very random. I have gone over and over songs where it’s happened and never got it to happen again. I will keep playing with it for now but might have to go back to 3.80 if it keeps happening.

1 Like


Is there some development with this upgrade ? Are we going to have an official release soon ?


We’re ironing out kinks with the paused state and receiving commands, this should be ready very soon!


BeatBuddy firmware version 3.9.9 has been posted above for download and the changelog has been updated!


It is not on the website 3.8 is the latest download there.

The download is located at the top of this thread. Scroll up.

Mini bug and a feature request.
When you Pause in an Intro or Outro, the display shows Part 1of 2 (or whatever). I’m not certain why someone would Pause in an Intro or Outro though, so it’s probably not very important to fix!
Can we have the old Pause behaviour back as an option (Pause then Stop stops the song even if it has an Outro). It was a good way to stop the drums cleanly if something went wrong.

You might want to pause in an intro or outro if the song is in OPB format. So, yes, if you want that as a option to operate the other way, I’m all for options.

Very nice job on the 3.9 manual! When this is out of beta, please be sure this gets posted to the Beat Buddy product page and then remove the separate out of date Midi Manual.


Assuming you have tried the new update already, can we not Stop the song silently after Pause? do we have to play the Outro if it exists?

As far as I know, with this update there is no way to Stop silently after Pause, if you also want to use Outros. (Unless you start using MIDI commands in OnSong or an external Midi pedal).

Hey there,

That is a small polish but thank you, we will look into that eventually.

Good news, to keep with the previous behavior when the footswitch pedal is set to outro and BB is paused and the BB stops immediately, we have added the option to set the External Footswitch/MIDI Outro command to split from the BB Outro setting if it is enabled and stop the song immediately like it did on 3.8.0. Simply go to Main Pedal > Unpause Behavior > External Unpause and set to Outro stops song. That external Footswitch must be set to send Outro while playing/paused.


Thanks, it’s a labor a of love and badly needed update!


Great. Thanks!

These are some nice improvements, especially the fixing of the double time midi clock. Also appreciate the manual improvement, good work there, lots of effort put in.
Just one request, the next part cc102, is great but it doesn’t work with my Boss loopers as the highest cc they can use is cc99 (Why would you do this Boss?) Anyway, is there an option to get next part cc102 to a cc below 99? Maybe a duplicate cc (as you use cc102 with Aeros) or option to toggle between 102 and 92?
Keep up the good work :slightly_smiling_face:

1 Like

Some folks use an Event Processor to deal with those issues.


…those BOSS issues. :slight_smile:

1 Like

Would bet it’s because they only allocated two digits of display on the screen. UI determining functionality… Well done boss.

1 Like

Two minor issues:

  • Footswitch Detector uses terms Left and Right and rest of settings use term #1 and #2. Should use one or the other term (e.g. #1 and #2 always). Even more confusing if your footswitch is oriented up and down. Perhaps use the term “#1 (left or bottom)”? I think that’s right but now I’m confused. Can also add to help text if not always enough room.
  • The Up/Down navigation while stopped is great. But you need to map your top, bottom buttons in the right order since you don’t control which moves up or down. Changes to the above labels work, but you could also add a setting to toggle this “direction”.

I’ve tested the issue I reported before about the fills causing the beat buddy to get out time, and it appears to be fixed.

To solve problems like this, consider Bome Midi Translator Pro software and/or BomeBox.

You configure and test midi “translations” in the software on a PC or Mac, then load the configuration file onto the BomeBox and then it all runs without a computer.

I have had huge success dealing with the idiosyncratic behavior of the midi implementations on my various gear, including BeatBuddy.

For example, I control my rig using Camelot Pro on my iPad. This app controls tempo quite nicely with BeatBuddy, but if I leave the tempo running on a song in Camelot, when I reopen the song, it starts running again. The midi clock it sends controls BB well, but at that moment it also sends midi start. This will start BB playing, which I want to control from my midi foot pedal.

I filtered out the midi start command from Camelot, and replaced it with a midi start from the BomeBox, initiated by my KMI Softstep pedal.

If you’re willing to invest some time in learning how the Bome app works, it will perform midi miracles for you.

I can’t recommend the Bome products highly enough to anyone who is technically inclined and willing to invest some time in perfecting their midi setup.