Beatbuddy to Infinity Looper midi sinc time signature problem

Up until now my beatbuddy as master and looper as slave have worked really great together for all my songs in 4/4 time. However, I recently made a song on beat buddy that is in 6/8 time and it is not syncing with my looper pedal at all. I can still see it is sending commands as though the song is in 4/4 time. The beat buddy is clearly in 6/8 time as the visual metronome shows but any setting i’ve tried on the beat buddy it is still sending in 4/4. It could possibly be a setting in my looper as well as, sure wish these two would get together and give us some more information on syncing.

Hi Brandon. 3 things that may or not help (which Support has already mentioned):

  1. Update the looper firmware if you haven’t done so already (although the Pigtronix blog does not mention it, I think they’re up to v.2.0.3)
  2. According to the Infinity blog, "New settings for Ignoring MIDI Clock received at the MIDI In port. This can be set from the Infinity Application’s “Tools->Global Boot Settings.”)
  3. I checked the Infinity Looper user guide because I recalled something about “4/4 being the default.” Here’s what I found on pages 39-40:
    "6.1 MIDI Sync p.39

MIDI Sync is the normal default MIDI mode of the Infinity−it’s always on.

When a MIDI Beat Clock is present, the Infinity Looper will synchronize its actions to the MIDI beat clock, acting as a slave device.

Once a loop has been recorded with a MIDI Beat Clock, the Infinity will constantly readjust the loop length to stay synchronized. This active MIDI synchronization prevents drift, and guarantees that all synchronized actions happen on time at the start of MIDI measures.

This active MIDI synchronization is designed to work with regular MIDI clock signals that don’t change tempo or time signature. If the MIDI clock signal does change tempo, the Infinity will react and adjust the sample rate gradually.

The MIDI actions of the Infinity are quantized to the measure when MIDI is running, by default in 4/4 time. Any action that is meant to obey MIDI clock will be applied at the beginning of the next measure (not necessarily the end of the loop cycle). So it’s best to cue the MIDI command within the bar/measure before you want it to occur, not right on the downbeat.

If a MIDI clock signal is present during recording and then stopped or disconnected, the Infinity will continue playback using its recorded length. Actions will continue to be quantized to an internal, approxi- mate MIDI clock. However, this internal MIDI clock may drift or differ from the external MIDI clock that was disabled.

6.2 Time Signature

The Time signature can be changed, on a preset-by-preset basis, using the Infinity Application. For quantization to the beat rather than to the measure, set the measure to a single note (eg. 1/2, 1/4, 1/8, 1/16). "

Thank you for the replies. I did update the firmware lastnight however in doing so I somehow lost the infinity looper applicaton when I connect it to the computer, the looperexe file is just gone so I have no way to get into the application. I have contaced infinity for guidance regarding that matter. I do however know I have the latest firmware as one of the updates is to allow the looper to fade for more than one loop cycle, which mine now has this function. However, not being able to get into the application is now a problem.

Persist I think the last point of 6.2 time signature is the answer, I am hoping anyway. When I initially synced the two I had to go into the infinity application and enable “ignore midi notes” or “ignore midi clock”, something like that I can’t remember exactly now but that was the only way it would work for me. Support, I tried MIDI OUT>Time Signature> both Enabled and Disabled and it made no difference either way.

I will post update once I can get back into the application. I am hoping they can just send me the application file and I can save it onto the looper. Not too sure how or why it is now gone but it is. Thanks again for the replies.

Maybe this helps…:

Brandon, to download the looper application, go to

If you’re referring to the application on the looper internal SD card, you should just be able to use the application on your computer to update the looper firmware and it should reinstall the app to the looper SD card.

Also, if you don’t hear from Pigtronix this weekend, you can try following the Pigtronix instructions from post 11 on this link

I checked the looper image contents and it looks like Pigtronix may have recently updated it.