Cannot Bring Up Settings

I just received my BeatBuddy and it is acting a little flaky. First, it sometimes displays “Default Tempo set to 100” (or the current tempo) when I hit the main pedal. The biggest problem is that I can’t get into the “Settings” area by pressing the “Drum Set” and the “Tempo” buttons at the same time. When I do this, I usually get a message “Default Drumset set as Standard” (or the current Drumset). I tried installing the latest flash as well as backing off the software by loading the full SD image, but the device responds the same. Please help.

Does the Tempo button on its own?

Thanks for the reply. Yes, the tempo does work on its own, but I discovered something while running your test. If I touch the knob just slightly, the “Default Tempo set to 100” message comes up. If I jiggle it just a little, sometimes the screen will go black then come back on after a moment. I think the switch has a switch or open. Are there other tests I can run? If it is a short, how should I proceed? Should I exchange it through the music store? Thanks!

If you would like to resolve this locally at your store, I would just make sure that you can access the settings menu on the replacement BeatBuddy before you walk out of the store with it. If you can access the settings, then trade it in and have them mark that unit defective. If not (the same things happens with the new one) it’s possible that the buttons aren’t being pressed in the correct fashion (maybe one button is being held slightly longer before the other one, just a possibility).

In any case, keep us updated. :slight_smile:

BeatBuddy_Support - is this a known issue with these? mine is acting the same way now and i see two posts on here regarding this, mine has been in the box for a few years and worked fine when i put it away, took it out today to start creating drum beats for a new duo I am forming, and i cannot access settings by pressing the Drum set and Tempo buttons together.



Since your pedal was sitting unused for so long, I recommend updating the firmware using your computer’s SD slot to do so.

Once your pedal has been updated, make sure you are using the power adaptor that came with the pedal. Which one of the two knobs doesn’t work or is it only when pressing both of them together that’s not working? Try exercising the knobs individually by clicking them and rotating them in both directions.

As you mentioned in your other post, you could also try a contact cleaner such as DeOxit.

Good luck and let us know how it all turns out.

I updated the firmware…no luck.
BUT…I took the knobs off and sprayed contact cleaner down into the posts. After a bit of working them…clicking and dialing them several times…and a second spray of contact cleaner …IT WORKED!

Thanks for the reply!



Thanks for letting us know how you got it working again.