Cannot Start/Stop Quantiloop with BeatBuddy - Please Help!

Hello, Folks

I’m having a problem getting Quantiloop to start/stop when I pause/start the BeatBuddy. It was working perfectly but now Quantiloop won’t start.

Everything else is working fine. I can set the tempo for Quantiloop; I can start and stop tracks with my AirTurn Stomp switch; I can change the Quantiloop bank and tracks all configured via OnSong. No issues. FYI, I set the tempo on the BB within OnSong which in turn sets the tempo in Quantiloop. This is working fine.

Also, I have an app called Midiflow running on the Quatiloop iPad with a config to capture midi command coming from the iRig Pro Duo going to Quantiloop. When tracking I see the midi clock signal coming from the BB. When I hit start I see a steam of midi commands generated by the BB sent to Channel 2 that continues while the BB is playing. The stream stops when I pause or stop the BB. Is this stream normal? They look like notes and program changes and they toggle on/off really fast.

OnSong>iConnect Mio cable>BB Midi-in>BB Midi-out>iRig Pro Duo Midi-in>iRig Duo mini-din out>Quantiloop

  • BeatBuddy Firmware 3.2.0
  • Quantiloop 2.93 (402)
  • BeatBuddy MIDI Channel = 1
  • BeatBuddy MIDI-out Channel = 2
  • Quantiloop MIDI Channel = 2
  • Quantiloop Rhythm Settings
    • Start on Play
    • Most songs are set to metronome
    • A few songs are set to BeatBuddy
    • When this is set BeatBuddy appears Offline.
  • Quantiloop is the end of the MIDI chain and is not configured to control the BeatBuddy.

BB Settings

  • Main Pedal - Mute Pause - Disabled
  • Main Pedal - MIDI Out Sync - Always on
  • Main Pedal - MIDI - MIDI Out Start - Enabled (Main Beat)
  • Main Pedal - MIDI - MIDI Out Stop - Pause and End

Did you perform any firmware, software or peripheral changes between the time it was working and now that it’s not?

No, actually I was running firmware 2.04 when it started happening. I updated it to 3.2.0 as troubleshooting step. (I was planning on doing this anyways but hadn’t gotten around to it).

I want to add that I tested this on an iPhone running Quantiloop and got the exact same behavior.

Come to think about it, this started when I attempted to configure Quantiloop to control the BB. As you know, QL has the ability to change folders and generate auto-fill when changing tracks. I messed around with this including making the QL the midi clock but the results were mixed, so I put everything back as it was. I disabled the setting that makes QL the midi clock.

I had an issue with the BB not stopping QL when I would pause. I submitted a ticket with QL support and got a reply from Stephan Marx. He solved that problem by telling me to make sure the Mute Pause was disabled. In fact, all of the BB settings I listed above were provided by Stephan in his reply.
It so happened that that Mute Pause had somehow got set to enabled. Once I disabled it, everything worked for weeks until I started messing around trying to get the BB settings in QL to work.

I’m stumped. Here is a link to YT vid I just uploaded showing the problem in realtime

Call Off The Dogs! Problem Solved. And I am a bit embarrassed to tell what it was, but here it goes:

Tempo Sync To was set to the iConnect Mio and not the iRig Pro Duo. Ugh!!!

Sorry for all the fuss (sigh)