Can't save song (or Aeros thinks the song isn't saved)

I press save, it looks like it’s saving (wait spinner comes up and goes away), but it’s not saved.

It started with not being able to update the name. Then I noticed the Aeros thinks the track is not saved in all the usual spots (save button still active, prompt to save when exiting, etc.) Tried going to other screens and coming back, but same issue.

The track is setup to save on the internal storage.

The only thing odd I can recall is first I tried to change the name unsuccessfully. Nothing odd in the name like spaces. I think the name is unique.

Pretty sure I pressed “Save” while the keyboard was up the first few times. I later tried exiting the keyboard before pressing save, but it did not fix it. (FYI “exit” from the keyboard or go-to next field is a pretty bad experience; not intuitive)

This was a new song, perhaps the first new one in v3.0 that I created.

The only things left for me to do is to create a new song and/or power cycle to verify the changes are lost.

Please PM me if you have anything you’d like me to try to debug this before I create another song and lose the ability to provide more info. @BeatBuddy_Support @BrennanSingularSound @DavidPackouz

Techinal Rambling: Do you have more than one thread running or multiple places the “state” of the song save is maintained that you try to keep in sync? Are you waiting for callbacks? UI threads can have subtle, non-reproducible issues with visibility, and it’s generally harder to protect yourself in embedded systems.

So I moved on, and it got weirder.

At some point I noticed the save button was disabled (but the name had not changed) so something had apparently saved?

I fooled around with editing the name some more. Same behavior.

The I went to “Songs” and there were two recent songs (one with the new name) and one with the old name. I didn’t duplicate the song (at least intentionally) . I can load the new song.

Bad news. The old named song one is still loading… ;-(

Seems like editing the name is core to the issue?

FYI, there was a song with the same name I chose. This is probably part of the issue.

The “old” song is not here after I power cycled from the hang.

Hi @Quad sorry to hear about this issue. Does it only happen when you name the song the same as an old song?

We did see these issues with previous beta firmware versions (which is why we didn’t release them officially), but we tested this extensively and we believe we fixed these issues with firmware 3.0. Maybe the old song you created was made with one of those old beta firmware versions and when you named the new song with the same name, the memory got confused – this shouldn’t have be possible to happen though, because when you try to use an identical name, it should not allow you to save it with the same name. Maybe the old corrupted song escaped our non-identical name system – this is good information for us to have.

If you see this happen with a song with a new name, please post a video of the problem so we can trouble shoot it – I personally prefer the google photos app because it’s free and you can just post a link.

Let me try. If it was an old song, it was using the default naming.

Reproducible with the the following steps (and with a newly created song). Almost impossible for me to hold the camera to record video and operate the Aeros. The issue happens when the name matches another song, but only when you ignore case (e.g., “Foo” versus “foo”). I have no idea how to recreate the state that later hung the Aeros in my initial report (when I deleted the "unsaved song with the old name in the song list

Caution: This bug report comes with a few off topic suggestions.

  1. Power On Aeros
  2. Goto Songs
  3. Press “+” (By the way since the scroll wheel navigates up and down, please reassign those footswitches to “New Song” and “Delete”. Add “Edit” on screen button. Or use 'em for something else. Also please slow down the rate at which the scroll wheel advances in the song list … possibly increasing the scroll speed after repeated rotations within some time period).
  4. Create Song
  5. Record something (may not be necessary)
  6. Stop
  7. Edit Song name to something unique (I used Save without exiting the keyboard)
  8. Note: Save button is disabled
  9. Press “+”
  10. Record something (may not be necessary)
  11. Edit Song name to same as above but with a difference in case (I used Save without exiting the keyboard)
  12. Bang: Save button is still enabled. song name has not changed
  13. Press Save or any other action in the loop studiot that leads to a save after confirming
  14. Bang: It looks like it’s saving, but no dice
  15. Edit song name one more time to be unique. Works as expected.

As I worked on this, I had to delete the currently loaded song which I can’t because it is loaded. Please remove the inability to delete the currently loaded song. It’s a royal pain and should be a small change.
Worthing fixing even if it’s a hack that “opens” an arbitrary other song before deleting and won’t work if there’s only one song in the device.

Another very minor issue: The title is displayed in upper case in the loop studio, but mixed case elsewhere.

Your reply suggests you are caching the directory contents rather than scanning the directory in real time. That’s faster and avoids a context switch, but keeping the two in sync adds to complexity, risk, etc.

@Quad thank you very much for your detailed report – extremely helpful. We are looking into this.

Regarding the ability to delete the current song, you can just ‘clear’ the song by holding down the play/stop all button. At that point you can change any setting you want, it’s like a new song. The way the Aeros is built, it has to have a song loaded at all times, so if you deleted the current song, it would need to load another song automatically.

That’s a neat trick of clearing and changing any song setting. If and until people figure that out, the experience is frustrating though. Just like polish, annoyances add up.

Loading the last song or an arbitrary song would be better than getting an an annoying prompt that you know (think) requires multiple steps between multiple screens. If you leave the person on the song selection screen after deleting and choosing another song, then they can select another song to load if that wasn’t right. In the ultra edge case of the last song on the device, just create a blank one … or do whatever you do when the device starts up for the very first time. Or you could handle the cases where a song isn’t loaded at all. Not a big deal either way.

P.S. I see that you can now edit the quantize settings after the first save (and upon clear all). That’s a nice improvement.

I scanned the thread, but the answer to this might still be in there if I read it more closely.

Anyway - the issue is this:

  1. I create and save a song (using +) …let’s say I name it SONG1
  2. Later I get tired of that song, so, using STOP and HOLD then PRESS to DELETE ALL I clear the track.
  3. I create a new song (I never used +, as it seems logical that I could save what I’m working on under a new name).
  4. Now I go to SAVE SONG press SAVE The saving process completes without error,
  5. Now I delete the song parts (delete all after stop)
  6. Reload the song from the library (name shows up and it loads) BUT
  7. The song is now EMPTY. No tracks are there

Is this a known issue?

Hello there,

This is not a bug, song deletion is a final decision, it is not undoable. Deleting a song “saves” it as empty.

Perhaps “Clear All” is a less confusing label?

Why would you save an empty song over the one that was saved? That’s not a decision… that’s destruction of a song.

Not sure if I’d agree, because it is a final decision so deletion makes sense here, I understand what you mean since the song is now “cleared” but Deletion sounds more permanent and it is permanent.

It is not really saving, it is just not trashing the empty song, this is so that you can constantly delete and restart the song as you go along. If Aeros deleted the song file (not only the audio files), this would change that behavior which is not a route we want to take. I only say ‘save’ because it is, like saving on the Aeros, an irreversible decision.

But DHallowell said he saved the song, and it was gone. He really saved the song. Normally a program would compare the save name, and give you a warning… you are about to overwrite another song.

The song name is not deleted, it is the same “song” you just delete the audio files

He saved over his song after deleting the audio files. I do that on purpose, but being as all your songs are called Song_1, Song_2, Song_3, eventually you will save over a file by accident.

The Aeros doesn’t allow saving a new song with the same name on one memory bank. I’m not sure the scenario you are describing is what happened.

He never stated the song name was the same, I believe

He said he made a new song without using + which means it had the same name… doesn’t it? I think. He just deleted the tracks. He said it seemed logical that he could change the name, but he wasn’t asked when saving. You know how some programs add the word copy to the same named file, or when you copy paste a file, or they just warn you.

Sorry for any confusion. This is one of those things, where, after you’ve updated the firmware and couple weeks have gone by … I can’t reproduce the issue.

What I want to be able to do – and now I DO seem to able to do it - is:

  1. Start a new song (using +) with a unique name.
  2. Record, say, a track or two.
  3. Save it.
  4. Power down, come back another day, and reload the song.
  5. Decide I can do better, so I delete all tracks and record new performances.
  6. Go to Save song (the pencil) and save with the same name it’s always had.
  7. Retrieve the song later.

I swear there were times where I’d get through step 6, and upon reload, the song (with no complaints from the system) would be ‘empty’ … my update performances would be gone.

Anyway – I can’t seem to make that happen again - so I’m not worried about it.
Just laying it out here for clarity.

Thanks for your attention.


1 Like

Odd, but thanks for clarifying Dave!